summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libpcre/libpcre2_10.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libpcre/libpcre2_10.22.bb')
-rw-r--r--meta/recipes-support/libpcre/libpcre2_10.22.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-support/libpcre/libpcre2_10.22.bb b/meta/recipes-support/libpcre/libpcre2_10.22.bb
new file mode 100644
index 0000000000..1e00ed54d1
--- /dev/null
+++ b/meta/recipes-support/libpcre/libpcre2_10.22.bb
@@ -0,0 +1,56 @@
1DESCRIPTION = "There are two major versions of the PCRE library. The \
2newest version is PCRE2, which is a re-working of the original PCRE \
3library to provide an entirely new API. The original, very widely \
4deployed PCRE library's API and feature are stable, future releases \
5 will be for bugfixes only. All new future features will be to PCRE2, \
6not the original PCRE 8.x series."
7SUMMARY = "Perl Compatible Regular Expressions version 2"
8HOMEPAGE = "http://www.pcre.org"
9SECTION = "devel"
10LICENSE = "BSD"
11LIC_FILES_CHKSUM = "file://LICENCE;md5=ab9633efd38d6f799398df2c248b5aec"
12
13SRC_URI = "https://ftp.pcre.org/pub/pcre/pcre2-${PV}.tar.bz2 \
14 file://pcre-cross.patch \
15"
16
17SRC_URI[md5sum] = "c0c02517938ee2b0d350d53edf450664"
18SRC_URI[sha256sum] = "b2b44619f4ac6c50ad74c2865fd56807571392496fae1c9ad7a70993d018f416"
19
20S = "${WORKDIR}/pcre2-${PV}"
21
22PROVIDES += "pcre2"
23DEPENDS += "bzip2 zlib"
24
25BINCONFIG = "${bindir}/pcre2-config"
26
27inherit autotools binconfig-disabled
28
29EXTRA_OECONF = "\
30 --enable-newline-is-lf \
31 --enable-rebuild-chartables \
32 --with-link-size=2 \
33 --with-match-limit=10000000 \
34"
35
36# Set LINK_SIZE in BUILD_CFLAGS given that the autotools bbclass use it to
37# set CFLAGS_FOR_BUILD, required for the libpcre build.
38BUILD_CFLAGS =+ "-DLINK_SIZE=2 -I${B}/src"
39CFLAGS += "-D_REENTRANT"
40CXXFLAGS_append_powerpc = " -lstdc++"
41
42export CCLD_FOR_BUILD ="${BUILD_CCLD}"
43
44PACKAGES =+ "pcre2grep pcre2grep-doc pcre2test pcre2test-doc"
45
46SUMMARY_pcre2grep = "grep utility that uses perl 5 compatible regexes"
47SUMMARY_pcre2grep-doc = "grep utility that uses perl 5 compatible regexes - docs"
48SUMMARY_pcre2test = "program for testing Perl-comatible regular expressions"
49SUMMARY_pcre2test-doc = "program for testing Perl-comatible regular expressions - docs"
50
51FILES_pcre2grep = "${bindir}/pcre2grep"
52FILES_pcre2grep-doc = "${mandir}/man1/pcre2grep.1"
53FILES_pcre2test = "${bindir}/pcre2test"
54FILES_pcre2test-doc = "${mandir}/man1/pcre2test.1"
55
56BBCLASSEXTEND = "native nativesdk"