summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libnl/libnl_3.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libnl/libnl_3.6.0.bb')
-rw-r--r--meta/recipes-support/libnl/libnl_3.6.0.bb78
1 files changed, 78 insertions, 0 deletions
diff --git a/meta/recipes-support/libnl/libnl_3.6.0.bb b/meta/recipes-support/libnl/libnl_3.6.0.bb
new file mode 100644
index 0000000000..af3aa41040
--- /dev/null
+++ b/meta/recipes-support/libnl/libnl_3.6.0.bb
@@ -0,0 +1,78 @@
1SUMMARY = "A library for applications dealing with netlink sockets"
2DESCRIPTION = "The libnl suite is a collection of libraries providing \
3APIs to netlink protocol based Linux kernel interfaces. libnl is the core \
4library implementing the fundamentals required to use the netlink protocol \
5such as socket handling, message construction and parsing, and sending \
6and receiving of data."
7HOMEPAGE = "http://www.infradead.org/~tgr/libnl/"
8SECTION = "libs/network"
9
10PE = "1"
11
12LICENSE = "LGPL-2.1-only"
13LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
14
15DEPENDS = "flex-native bison-native"
16
17SRC_URI = " \
18 https://github.com/thom311/${BPN}/releases/download/${BPN}${@d.getVar('PV').replace('.','_')}/${BP}.tar.gz \
19 file://enable-serial-tests.patch \
20 file://run-ptest \
21 file://fa7f97f8982544c4fcb403893bae6701230d5165.patch \
22 "
23
24SRC_URI[sha256sum] = "532155fd011e5a805bd67121b87a01c757e2bb24112ac17e69cb86013b970009"
25
26
27UPSTREAM_CHECK_URI = "https://github.com/thom311/${BPN}/releases"
28
29inherit autotools pkgconfig ptest
30
31FILES:${PN} = "${libdir}/libnl-3.so.* \
32 ${libdir}/libnl.so.* \
33 ${sysconfdir}"
34RREPLACES:${PN} = "libnl2"
35RCONFLICTS:${PN} = "libnl2"
36
37FILES:${PN}-dev += "${libdir}/libnl/cli/*/*.la"
38FILES:${PN}-staticdev += "${libdir}/libnl/cli/*/*.a"
39
40PACKAGES += "${PN}-cli ${PN}-genl ${PN}-idiag ${PN}-nf ${PN}-route ${PN}-xfrm"
41FILES:${PN}-cli = "${libdir}/libnl-cli-3.so.* \
42 ${libdir}/libnl/cli/*/*.so \
43 ${bindir}/genl-ctrl-list \
44 ${bindir}/idiag-socket-details \
45 ${bindir}/nf-* \
46 ${bindir}/nl-*"
47FILES:${PN}-genl = "${libdir}/libnl-genl-3.so.* \
48 ${libdir}/libnl-genl.so.*"
49FILES:${PN}-idiag = "${libdir}/libnl-idiag-3.so.*"
50FILES:${PN}-nf = "${libdir}/libnl-nf-3.so.*"
51FILES:${PN}-route = "${libdir}/libnl-route-3.so.*"
52FILES:${PN}-xfrm = "${libdir}/libnl-xfrm-3.so.*"
53RREPLACES:${PN}-genl = "libnl-genl2"
54RCONFLICTS:${PN}-genl = "libnl-genl2"
55
56RDEPENDS:${PN}-ptest += "libcheck"
57RRECOMMENDS:${PN}-ptest += "kernel-module-dummy kernel-module-bonding"
58DEPENDS += "${@bb.utils.contains('PTEST_ENABLED', '1', 'libcheck', '', d)}"
59
60# make sure the tests don't link against wrong so file
61EXTRA_OECONF += "${@bb.utils.contains('PTEST_ENABLED', '1', '--disable-rpath', '', d)}"
62
63do_compile_ptest() {
64 # hack to remove the call to `make runtest-TESTS`
65 sed -i 's/$(MAKE) $(AM_MAKEFLAGS) runtest-TESTS//g' Makefile
66 oe_runmake check
67}
68
69do_install_ptest(){
70 # legacy? tests are also installed, but ptest-runner will not run them
71 # upstream are not running these tests in their CI pipeline
72 # issue opened https://github.com/thom311/libnl/issues/270
73 install -m 0755 tests/.libs/* ${D}${PTEST_PATH}/
74 # contains build paths
75 rm ${D}${PTEST_PATH}/*.la
76}
77
78BBCLASSEXTEND = "native nativesdk"