summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb')
-rw-r--r--meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb b/meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb
new file mode 100644
index 0000000000..0628ee71b5
--- /dev/null
+++ b/meta/recipes-support/libmicrohttpd/libmicrohttpd_1.0.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "A small C library that is supposed to make it easy to run an HTTP server as part of another application"
2HOMEPAGE = "http://www.gnu.org/software/libmicrohttpd/"
3LICENSE = "LGPL-2.1-or-later"
4LIC_FILES_CHKSUM = "file://COPYING;md5=57d09285feac8a64efa878e692b14f36"
5SECTION = "net"
6
7DEPENDS = "file"
8
9SRC_URI = "${GNU_MIRROR}/libmicrohttpd/${BPN}-${PV}.tar.gz"
10SRC_URI[sha256sum] = "a89e09fc9b4de34dde19f4fcb4faaa1ce10299b9908db1132bbfa1de47882b94"
11
12inherit autotools lib_package pkgconfig gettext
13
14CFLAGS += "-pthread -D_REENTRANT"
15
16EXTRA_OECONF += "--disable-static --with-gnutls=${STAGING_LIBDIR}/../ --enable-largefile"
17
18PACKAGECONFIG ?= "curl https"
19
20PACKAGECONFIG[curl] = "--enable-curl,--disable-curl,curl,"
21PACKAGECONFIG[https] = "--enable-https,--disable-https,libgcrypt gnutls,"
22
23do_compile:append() {
24 sed -i s:-L${STAGING_LIBDIR}::g libmicrohttpd.pc
25}
26
27BBCLASSEXTEND = "native nativesdk"