summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb')
-rw-r--r--meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb b/meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb
new file mode 100644
index 0000000000..6cef8c068c
--- /dev/null
+++ b/meta/recipes-support/libjitterentropy/libjitterentropy_3.4.1.bb
@@ -0,0 +1,27 @@
1SUMMARY = "Hardware RNG based on CPU timing jitter"
2DESCRIPTION = "The Jitter RNG provides a noise source using the CPU execution timing jitter. \
3It does not depend on any system resource other than a high-resolution time \
4stamp. It is a small-scale, yet fast entropy source that is viable in almost \
5all environments and on a lot of CPU architectures."
6HOMEPAGE = "http://www.chronox.de/jent.html"
7LICENSE = "GPL-2.0-or-later | BSD-3-Clause"
8LIC_FILES_CHKSUM = "file://LICENSE;md5=64a87180908540620ce364b5e69b3b03 \
9 file://LICENSE.gplv2;md5=eb723b61539feef013de476e68b5c50a \
10 file://LICENSE.bsd;md5=66a5cedaf62c4b2637025f049f9b826f \
11 "
12SRC_URI = "git://github.com/smuellerDD/jitterentropy-library.git;branch=master;protocol=https"
13SRCREV = "4544e11320138ac02797af81766f4476a71bb09f"
14S = "${WORKDIR}/git"
15
16do_configure[noexec] = "1"
17
18LDFLAGS += "-Wl,-O0"
19
20do_install () {
21 oe_runmake install INCDIR="/include" \
22 DESTDIR="${D}" \
23 PREFIX="${exec_prefix}" \
24 LIBDIR="${baselib}" \
25 INSTALL_STRIP="install"
26}
27