summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.8.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.8.bb46
1 files changed, 0 insertions, 46 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.8.bb b/meta/recipes-support/libical/libical_3.0.8.bb
deleted file mode 100644
index 6230f09eca..0000000000
--- a/meta/recipes-support/libical/libical_3.0.8.bb
+++ /dev/null
@@ -1,46 +0,0 @@
1SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2HOMEPAGE = "https://github.com/libical/libical"
3BUGTRACKER = "https://github.com/libical/libical/issues"
4LICENSE = "LGPLv2.1 | MPL-2.0"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
6 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
7 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
8 "
9SECTION = "libs"
10
11SRC_URI = " \
12 https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
13 file://0001-Use-our-hand-build-native-src-generator.patch \
14 file://0001-Fix-build-with-icu-68.1.patch \
15"
16SRC_URI[md5sum] = "41bd1f1fcdcb4779cea478bb55cf07bf"
17SRC_URI[sha256sum] = "09fecacaf75ba5a242159e3a9758a5446b5ce4d0ab684f98a7040864e1d1286f"
18UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
19
20inherit cmake pkgconfig
21
22do_compile_prepend() {
23 # As long as https://github.com/libical/libical/issues/394 is open build native src-generator manually
24 NATIVE_CFLAGS="${BUILD_CFLAGS} `pkg-config-native --cflags glib-2.0` `pkg-config-native --cflags libxml-2.0`"
25 NATIVE_LDFLAGS="${BUILD_LDFLAGS} `pkg-config-native --libs glib-2.0` `pkg-config-native --libs libxml-2.0`"
26 ${BUILD_CC} $NATIVE_CFLAGS ${S}/src/libical-glib/tools/generator.c ${S}/src/libical-glib/tools/xml-parser.c -o ${B}/src-generator $NATIVE_LDFLAGS
27}
28
29PACKAGECONFIG ??= "icu glib"
30PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
31PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
32# ICU is used for RSCALE (RFC7529) support
33PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
34
35# No need to use perl-native, the host perl is sufficient.
36EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
37# doc build fails with linker error (??) for libical-glib so disable it
38EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
39
40do_install_append () {
41 # Remove build host references
42 sed -i \
43 -e 's,${STAGING_LIBDIR},${libdir},g' \
44 -e 's,${STAGING_INCDIR},${includedir},g' \
45 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake
46}