summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libical/libical_3.0.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libical/libical_3.0.10.bb')
-rw-r--r--meta/recipes-support/libical/libical_3.0.10.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/libical/libical_3.0.10.bb b/meta/recipes-support/libical/libical_3.0.10.bb
new file mode 100644
index 0000000000..30d6bbfd0f
--- /dev/null
+++ b/meta/recipes-support/libical/libical_3.0.10.bb
@@ -0,0 +1,46 @@
1SUMMARY = "iCal and scheduling (RFC 2445, 2446, 2447) library"
2DESCRIPTION = "An Open Source implementation of the iCalendar protocols \
3and protocol data units. The iCalendar specification describes how \
4calendar clients can communicate with calendar servers so users can store \
5their calendar data and arrange meetings with other users. "
6HOMEPAGE = "https://github.com/libical/libical"
7BUGTRACKER = "https://github.com/libical/libical/issues"
8LICENSE = "LGPLv2.1 | MPL-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=1910a2a76ddf6a9ba369182494170d87 \
10 file://LICENSE.LGPL21.txt;md5=933adb561f159e7c3da079536f0ed871 \
11 file://LICENSE.MPL2.txt;md5=f75d2927d3c1ed2414ef72048f5ad640 \
12 "
13SECTION = "libs"
14
15SRC_URI = "https://github.com/${BPN}/${BPN}/releases/download/v${PV}/${BP}.tar.gz \
16"
17SRC_URI[sha256sum] = "f933b3e6cf9d56a35bb5625e8e4a9c3a50239a85aea05ed842932c1a1dc336b4"
18UPSTREAM_CHECK_URI = "https://github.com/libical/libical/releases"
19
20inherit cmake pkgconfig
21
22DEPENDS_append_class-target = "libical-native"
23
24PACKAGECONFIG ??= "icu glib"
25PACKAGECONFIG[bdb] = ",-DCMAKE_DISABLE_FIND_PACKAGE_BDB=True,db"
26PACKAGECONFIG[glib] = "-DICAL_GLIB=True,-DICAL_GLIB=False,glib-2.0-native libxml2-native glib-2.0 libxml2"
27# ICU is used for RSCALE (RFC7529) support
28PACKAGECONFIG[icu] = ",-DCMAKE_DISABLE_FIND_PACKAGE_ICU=True,icu"
29
30# No need to use perl-native, the host perl is sufficient.
31EXTRA_OECMAKE += "-DPERL_EXECUTABLE=${HOSTTOOLS_DIR}/perl"
32# doc build fails with linker error (??) for libical-glib so disable it
33EXTRA_OECMAKE += "-DICAL_BUILD_DOCS=false"
34
35EXTRA_OECMAKE_append_class-target = " -DIMPORT_ICAL_GLIB_SRC_GENERATOR=${STAGING_LIBDIR_NATIVE}/cmake/LibIcal/IcalGlibSrcGenerator.cmake"
36
37do_install_append () {
38 # Remove build host references
39 sed -i \
40 -e 's,${STAGING_LIBDIR},${libdir},g' \
41 -e 's,${STAGING_INCDIR},${includedir},g' \
42 ${D}${libdir}/cmake/LibIcal/LibIcal*.cmake \
43 ${D}${libdir}/cmake/LibIcal/Ical*.cmake
44}
45
46BBCLASSEXTEND = "native"