summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.48.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.48.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.48.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.48.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.48.bb
new file mode 100644
index 0000000000..9f2b49209d
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.48.bb
@@ -0,0 +1,53 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2DESCRIPTION = "Contains common error codes and error handling functions used by GnuPG, Libgcrypt, GPGME and more packages. "
3HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
4BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
5
6LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
7LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
8 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
9 file://src/gpg-error.h.in;beginline=2;endline=18;md5=20f4cf5d81ea2fad18f6297500018654 \
10 file://src/init.c;beginline=2;endline=17;md5=f01cdfcf747af5380590cfd9bbfeaaf7 \
11 "
12
13
14SECTION = "libs"
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
18 file://pkgconfig.patch \
19 file://0001-Do-not-fail-when-testing-config-scripts.patch \
20 file://run-ptest \
21 "
22
23SRC_URI[sha256sum] = "89ce1ae893e122924b858de84dc4f67aae29ffa610ebf668d5aa539045663d6f"
24
25BINCONFIG = "${bindir}/gpg-error-config"
26
27inherit autotools binconfig-disabled pkgconfig gettext multilib_header multilib_script ptest
28
29RDEPENDS:${PN}-ptest:append = " make bash"
30
31MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/gpgrt-config"
32
33CPPFLAGS += "-P"
34
35do_install:append() {
36 # we don't have common lisp in OE
37 rm -rf "${D}${datadir}/common-lisp/"
38 oe_multilib_header gpg-error.h gpgrt.h
39}
40
41do_compile_ptest() {
42 oe_runmake -C tests buildtest-TESTS
43}
44
45do_install_ptest() {
46 install ${B}/tests/t-*[!\.o] ${D}${PTEST_PATH}
47 install ${B}/tests/Makefile ${D}${PTEST_PATH}
48}
49
50FILES:${PN}-dev += "${bindir}/gpg-error"
51FILES:${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
52
53BBCLASSEXTEND = "native nativesdk"