summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgpg-error/libgpg-error_1.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgpg-error/libgpg-error_1.31.bb')
-rw-r--r--meta/recipes-support/libgpg-error/libgpg-error_1.31.bb61
1 files changed, 61 insertions, 0 deletions
diff --git a/meta/recipes-support/libgpg-error/libgpg-error_1.31.bb b/meta/recipes-support/libgpg-error/libgpg-error_1.31.bb
new file mode 100644
index 0000000000..5dd861501e
--- /dev/null
+++ b/meta/recipes-support/libgpg-error/libgpg-error_1.31.bb
@@ -0,0 +1,61 @@
1SUMMARY = "Small library that defines common error values for all GnuPG components"
2HOMEPAGE = "http://www.gnupg.org/related_software/libgpg-error/"
3BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
4
5LICENSE = "GPLv2+ & LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
8 file://src/gpg-error.h.in;endline=19;md5=e9be7dd9dc7686d91b5421a091c212cc \
9 file://src/init.c;endline=20;md5=872b2389fe9bae7ffb80d2b91225afbc"
10
11
12SECTION = "libs"
13
14UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
15SRC_URI = "${GNUPG_MIRROR}/libgpg-error/libgpg-error-${PV}.tar.bz2 \
16 file://pkgconfig.patch \
17 "
18SRC_URI[md5sum] = "5cc6df0fea27832e9cdbafc60f51561b"
19SRC_URI[sha256sum] = "40d0a823c9329478063903192a1f82496083b277265904878f4bc09e0db7a4ef"
20
21BINCONFIG = "${bindir}/gpg-error-config"
22
23inherit autotools binconfig-disabled pkgconfig gettext multilib_header
24CPPFLAGS += "-P"
25do_compile_prepend() {
26 TARGET_FILE=linux-gnu
27 if [ ${TARGET_OS} = "mingw32" ]; then
28 # There are no arch specific syscfg files for mingw32
29 TARGET_FILE=
30 elif [ ${TARGET_OS} != "linux" ]; then
31 TARGET_FILE=${TARGET_OS}
32 fi
33
34 case ${TARGET_ARCH} in
35 aarch64_be) TUPLE=aarch64-unknown-linux-gnu ;;
36 arm) TUPLE=arm-unknown-linux-gnueabi ;;
37 armeb) TUPLE=arm-unknown-linux-gnueabi ;;
38 i586|i686) TUPLE=i686-pc-linux-gnu ;;
39 mips64*) TUPLE=mips64el-unknown-linux-gnuabi64 ;;
40 mips*el) TUPLE=mipsel-unknown-linux-gnu ;;
41 mips*) TUPLE=mips-unknown-linux-gnu ;;
42 x86_64) TUPLE=x86_64-pc-linux-gnu ;;
43 *) TUPLE=${TARGET_ARCH}-unknown-linux-gnu ;;
44 esac
45
46 if [ -n "$TARGET_FILE" ]; then
47 cp ${S}/src/syscfg/lock-obj-pub.$TUPLE.h \
48 ${S}/src/syscfg/lock-obj-pub.$TARGET_FILE.h
49 fi
50}
51
52do_install_append() {
53 # we don't have common lisp in OE
54 rm -rf "${D}${datadir}/common-lisp/"
55 oe_multilib_header gpg-error.h gpgrt.h
56}
57
58FILES_${PN}-dev += "${bindir}/gpg-error"
59FILES_${PN}-doc += "${datadir}/libgpg-error/errorref.txt"
60
61BBCLASSEXTEND = "native nativesdk"