summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb
index fd3d8e09f2..dee936dbc4 100644
--- a/meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.9.3.bb
@@ -8,9 +8,9 @@ SECTION = "libs"
8 8
9# helper program gcryptrnd and getrandom are under GPL, rest LGPL 9# helper program gcryptrnd and getrandom are under GPL, rest LGPL
10LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+" 10LICENSE = "GPLv2+ & LGPLv2.1+ & GPLv3+"
11LICENSE_${PN} = "LGPLv2.1+" 11LICENSE:${PN} = "LGPLv2.1+"
12LICENSE_${PN}-dev = "GPLv2+ & LGPLv2.1+" 12LICENSE:${PN}-dev = "GPLv2+ & LGPLv2.1+"
13LICENSE_dumpsexp-dev = "GPLv3+" 13LICENSE:dumpsexp-dev = "GPLv3+"
14 14
15LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ 15LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
16 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \ 16 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
@@ -37,25 +37,25 @@ BINCONFIG = "${bindir}/libgcrypt-config"
37inherit autotools texinfo binconfig-disabled pkgconfig 37inherit autotools texinfo binconfig-disabled pkgconfig
38 38
39EXTRA_OECONF = "--disable-asm" 39EXTRA_OECONF = "--disable-asm"
40EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'" 40EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
41 41
42PACKAGECONFIG ??= "capabilities" 42PACKAGECONFIG ??= "capabilities"
43PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap" 43PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
44 44
45do_configure_prepend () { 45do_configure:prepend () {
46 # Else this could be used in preference to the one in aclocal-copy 46 # Else this could be used in preference to the one in aclocal-copy
47 rm -f ${S}/m4/gpg-error.m4 47 rm -f ${S}/m4/gpg-error.m4
48} 48}
49 49
50# libgcrypt.pc is added locally and thus installed here 50# libgcrypt.pc is added locally and thus installed here
51do_install_append() { 51do_install:append() {
52 install -d ${D}/${libdir}/pkgconfig 52 install -d ${D}/${libdir}/pkgconfig
53 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/ 53 install -m 0644 ${B}/src/libgcrypt.pc ${D}/${libdir}/pkgconfig/
54} 54}
55 55
56PACKAGES =+ "dumpsexp-dev" 56PACKAGES =+ "dumpsexp-dev"
57 57
58FILES_${PN}-dev += "${bindir}/hmac256" 58FILES:${PN}-dev += "${bindir}/hmac256"
59FILES_dumpsexp-dev += "${bindir}/dumpsexp" 59FILES:dumpsexp-dev += "${bindir}/dumpsexp"
60 60
61BBCLASSEXTEND = "native nativesdk" 61BBCLASSEXTEND = "native nativesdk"