summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb')
-rw-r--r--meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb55
1 files changed, 55 insertions, 0 deletions
diff --git a/meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb b/meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb
new file mode 100644
index 0000000000..5a76201ab5
--- /dev/null
+++ b/meta/recipes-support/libgcrypt/libgcrypt_1.10.3.bb
@@ -0,0 +1,55 @@
1SUMMARY = "General purpose cryptographic library based on the code from GnuPG"
2DESCRIPTION = "A cryptography library developed as a separated module of GnuPG. \
3It can also be used independently of GnuPG, but depends on its error-reporting \
4library Libgpg-error."
5HOMEPAGE = "http://directory.fsf.org/project/libgcrypt/"
6BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
7SECTION = "libs"
8
9# helper program gcryptrnd and getrandom are under GPL, rest LGPL
10LICENSE = "GPL-2.0-or-later & LGPL-2.1-or-later"
11LICENSE:${PN} = "LGPL-2.1-or-later"
12LICENSE:${PN}-dev = "GPL-2.0-or-later & LGPL-2.1-or-later"
13
14LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://COPYING.LIB;md5=bbb461211a33b134d42ed5ee802b37ff \
16 file://LICENSES;md5=ef545b6cc717747072616519a1256d69 \
17 "
18
19DEPENDS = "libgpg-error"
20
21UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
22SRC_URI = "${GNUPG_MIRROR}/libgcrypt/libgcrypt-${PV}.tar.bz2 \
23 file://0001-libgcrypt-fix-m4-file-for-oe-core.patch \
24 file://0002-libgcrypt-fix-building-error-with-O2-in-sysroot-path.patch \
25 file://0004-tests-Makefile.am-fix-undefined-reference-to-pthread.patch \
26 file://no-native-gpg-error.patch \
27 file://no-bench-slope.patch \
28 file://run-ptest \
29 "
30SRC_URI[sha256sum] = "8b0870897ac5ac67ded568dcfadf45969cfa8a6beb0fd60af2a9eadc2a3272aa"
31
32BINCONFIG = "${bindir}/libgcrypt-config"
33
34inherit autotools texinfo binconfig-disabled pkgconfig ptest
35
36EXTRA_OECONF = "--disable-asm"
37EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
38
39PACKAGECONFIG ??= "capabilities"
40PACKAGECONFIG[capabilities] = "--with-capabilities,--without-capabilities,libcap"
41
42do_configure:prepend () {
43 # Else this could be used in preference to the one in aclocal-copy
44 rm -f ${S}/m4/gpg-error.m4
45}
46
47do_install_ptest() {
48 cd tests
49 oe_runmake testdrv-build testdrv
50 install testdrv $(srcdir=${S}/tests ./testdrv-build --files | sort | uniq) ${D}${PTEST_PATH}
51}
52
53FILES:${PN}-dev += "${bindir}/hmac256 ${bindir}/dumpsexp"
54
55BBCLASSEXTEND = "native nativesdk"