summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libffi/libffi_3.4.6.bb')
-rw-r--r--meta/recipes-support/libffi/libffi_3.4.6.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.4.6.bb b/meta/recipes-support/libffi/libffi_3.4.6.bb
new file mode 100644
index 0000000000..a6857a3981
--- /dev/null
+++ b/meta/recipes-support/libffi/libffi_3.4.6.bb
@@ -0,0 +1,32 @@
1SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=1db54c9fd307a12218766c3c7f650ca7"
12
13SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
15 "
16SRC_URI[sha256sum] = "b0dea9df23c863a7a50e825440f3ebffabd65df1497108e5d437747843895a4e"
17
18EXTRA_OECONF += "--disable-builddir --disable-exec-static-tramp"
19EXTRA_OECONF:class-native += "--with-gcc-arch=generic"
20EXTRA_OEMAKE:class-target = "LIBTOOLFLAGS='--tag=CC'"
21
22inherit autotools texinfo multilib_header github-releases
23
24do_install:append() {
25 oe_multilib_header ffi.h ffitarget.h
26}
27
28# Doesn't compile in MIPS16e mode due to use of hand-written
29# assembly
30MIPS_INSTRUCTION_SET = "mips"
31
32BBCLASSEXTEND = "native nativesdk"