summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libffi/libffi_3.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libffi/libffi_3.3.bb')
-rw-r--r--meta/recipes-support/libffi/libffi_3.3.bb42
1 files changed, 0 insertions, 42 deletions
diff --git a/meta/recipes-support/libffi/libffi_3.3.bb b/meta/recipes-support/libffi/libffi_3.3.bb
deleted file mode 100644
index 10ef003242..0000000000
--- a/meta/recipes-support/libffi/libffi_3.3.bb
+++ /dev/null
@@ -1,42 +0,0 @@
1SUMMARY = "A portable foreign function interface library"
2HOMEPAGE = "http://sourceware.org/libffi/"
3DESCRIPTION = "The `libffi' library provides a portable, high level programming interface to various calling \
4conventions. This allows a programmer to call any function specified by a call interface description at run \
5time. FFI stands for Foreign Function Interface. A foreign function interface is the popular name for the \
6interface that allows code written in one language to call code written in another language. The `libffi' \
7library really only provides the lowest, machine dependent layer of a fully featured foreign function interface. \
8A layer must exist above `libffi' that handles type conversions for values passed between the two languages."
9
10LICENSE = "MIT"
11LIC_FILES_CHKSUM = "file://LICENSE;md5=492385fe22195952f5b9b197868ba268"
12
13SRC_URI = "https://github.com/libffi/libffi/releases/download/v${PV}/${BPN}-${PV}.tar.gz \
14 file://not-win32.patch \
15 file://0001-Fixed-missed-ifndef-for-__mips_soft_float.patch \
16 file://0001-arm-sysv-reverted-clang-VFP-mitigation.patch \
17 file://0001-powerpc-fix-build-failure-on-power7-and-older-532.patch \
18 file://0001-Address-platforms-with-no-__int128.patch \
19 file://0001-Address-platforms-with-no-__int128-part2.patch \
20 file://0001-ffi_powerpc.h-fix-build-failure-with-powerpc7.patch \
21 "
22SRC_URI[md5sum] = "6313289e32f1d38a9df4770b014a2ca7"
23SRC_URI[sha256sum] = "72fba7922703ddfa7a028d513ac15a85c8d54c8d67f55fa5a4802885dc652056"
24UPSTREAM_CHECK_URI = "https://github.com/libffi/libffi/releases/"
25UPSTREAM_CHECK_REGEX = "libffi-(?P<pver>\d+(\.\d+)+)\.tar"
26
27EXTRA_OECONF += "--disable-builddir"
28EXTRA_OEMAKE_class-target = "LIBTOOLFLAGS='--tag=CC'"
29inherit autotools texinfo multilib_header
30
31do_install_append() {
32 oe_multilib_header ffi.h ffitarget.h
33}
34
35FILES_${PN}-dev += "${libdir}/libffi-${PV}"
36
37# Doesn't compile in MIPS16e mode due to use of hand-written
38# assembly
39MIPS_INSTRUCTION_SET = "mips"
40
41BBCLASSEXTEND = "native nativesdk"
42