summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libexif/libexif_0.6.24.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libexif/libexif_0.6.24.bb')
-rw-r--r--meta/recipes-support/libexif/libexif_0.6.24.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-support/libexif/libexif_0.6.24.bb b/meta/recipes-support/libexif/libexif_0.6.24.bb
new file mode 100644
index 0000000000..b407ee52de
--- /dev/null
+++ b/meta/recipes-support/libexif/libexif_0.6.24.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2DESCRIPTION = "libexif is a library for parsing, editing, and saving EXIF data. It is \
3intended to replace lots of redundant implementations in command-line \
4utilities and programs with GUIs."
5HOMEPAGE = "https://libexif.github.io/"
6SECTION = "libs"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
9
10SRC_URI = "${GITHUB_BASE_URI}/download/v${PV}/libexif-${PV}.tar.bz2 \
11 file://0001-Add-serial-tests-config-needed-by-ptest.patch \
12 file://run-ptest \
13 "
14
15SRC_URI[sha256sum] = "d47564c433b733d83b6704c70477e0a4067811d184ec565258ac563d8223f6ae"
16
17inherit autotools gettext github-releases ptest
18
19EXTRA_OECONF += "--disable-docs"
20
21do_compile_ptest() {
22 oe_runmake -C test buildtest-TESTS
23}
24
25do_install_ptest() {
26 install ${B}/test/test*[!\.o] ${D}${PTEST_PATH}
27 for f in ${D}${PTEST_PATH}/test*; do
28 sed -i "s/\(LD_LIBRARY_PATH=\).*\(:\$LD_LIBRARY_PATH\)\"/\1.\2/" $f
29 done
30
31 install ${B}/test/Makefile ${D}${PTEST_PATH}
32 sed -i -e "/^srcdir/c srcdir = \$\{PWD\}" ${D}${PTEST_PATH}/Makefile
33
34 install -d ${D}${PTEST_PATH}/nls
35 install ${B}/test/nls/*[!\.o] ${D}${PTEST_PATH}/nls
36 install -d ${D}${PTEST_PATH}/.libs
37 install ${B}/test/.libs/* ${D}${PTEST_PATH}/.libs
38
39 install ${S}/test/*.sh ${D}${PTEST_PATH}
40
41 install -d ${D}${PTEST_PATH}/testdata
42 install ${S}/test/testdata/* ${D}${PTEST_PATH}/testdata
43}
44
45RDEPENDS:${PN}-ptest += "make bash"
46
47BBCLASSEXTEND = "native nativesdk"