summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libexif/libexif_0.6.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libexif/libexif_0.6.22.bb')
-rw-r--r--meta/recipes-support/libexif/libexif_0.6.22.bb23
1 files changed, 0 insertions, 23 deletions
diff --git a/meta/recipes-support/libexif/libexif_0.6.22.bb b/meta/recipes-support/libexif/libexif_0.6.22.bb
deleted file mode 100644
index dc30926c59..0000000000
--- a/meta/recipes-support/libexif/libexif_0.6.22.bb
+++ /dev/null
@@ -1,23 +0,0 @@
1SUMMARY = "Library for reading extended image information (EXIF) from JPEG files"
2HOMEPAGE = "https://libexif.github.io/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1"
5LIC_FILES_CHKSUM = "file://COPYING;md5=243b725d71bb5df4a1e5920b344b86ad"
6
7def version_underscore(v):
8 return "_".join(v.split("."))
9
10SRC_URI = "https://github.com/libexif/libexif/releases/download/libexif-${@version_underscore("${PV}")}-release/libexif-${PV}.tar.xz \
11 file://CVE-2020-0198.patch \
12 file://CVE-2020-0452.patch \
13 "
14
15SRC_URI[sha256sum] = "5048f1c8fc509cc636c2f97f4b40c293338b6041a5652082d5ee2cf54b530c56"
16
17UPSTREAM_CHECK_URI = "https://github.com/libexif/libexif/releases/"
18
19inherit autotools gettext
20
21EXTRA_OECONF += "--disable-docs"
22
23BBCLASSEXTEND = "native nativesdk"