summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libevent/libevent_2.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libevent/libevent_2.1.8.bb')
-rw-r--r--meta/recipes-support/libevent/libevent_2.1.8.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-support/libevent/libevent_2.1.8.bb b/meta/recipes-support/libevent/libevent_2.1.8.bb
new file mode 100644
index 0000000000..1270d627f8
--- /dev/null
+++ b/meta/recipes-support/libevent/libevent_2.1.8.bb
@@ -0,0 +1,42 @@
1SUMMARY = "An asynchronous event notification library"
2HOMEPAGE = "http://libevent.org/"
3BUGTRACKER = "https://github.com/libevent/libevent/issues"
4SECTION = "libs"
5
6LICENSE = "BSD & MIT"
7LIC_FILES_CHKSUM = "file://LICENSE;md5=17f20574c0b154d12236d5fbe964f549"
8
9SRC_URI = " \
10 https://github.com/libevent/libevent/releases/download/release-${PV}-stable/${BP}-stable.tar.gz \
11 file://Makefile-missing-test-dir.patch \
12 file://run-ptest \
13"
14
15SRC_URI[md5sum] = "f3eeaed018542963b7d2416ef1135ecc"
16SRC_URI[sha256sum] = "965cc5a8bb46ce4199a47e9b2c9e1cae3b137e8356ffdad6d94d3b9069b71dc2"
17
18UPSTREAM_CHECK_URI = "http://libevent.org/"
19
20S = "${WORKDIR}/${BPN}-${PV}-stable"
21
22PACKAGECONFIG ??= ""
23PACKAGECONFIG[openssl] = "--enable-openssl,--disable-openssl,openssl"
24
25inherit autotools
26
27# Needed for Debian packaging
28LEAD_SONAME = "libevent-2.1.so"
29
30inherit ptest
31
32DEPENDS = "zlib"
33
34BBCLASSEXTEND = "native nativesdk"
35
36do_install_ptest() {
37 install -d ${D}${PTEST_PATH}/test
38 for file in ${B}/test/.libs/regress ${B}/test/.libs/test*
39 do
40 install -m 0755 $file ${D}${PTEST_PATH}/test
41 done
42}