summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcheck/libcheck_0.15.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcheck/libcheck_0.15.2.bb')
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.15.2.bb24
1 files changed, 16 insertions, 8 deletions
diff --git a/meta/recipes-support/libcheck/libcheck_0.15.2.bb b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
index 33e07db93c..5ab67b8728 100644
--- a/meta/recipes-support/libcheck/libcheck_0.15.2.bb
+++ b/meta/recipes-support/libcheck/libcheck_0.15.2.bb
@@ -1,28 +1,36 @@
1SUMMARY = "Check - unit testing framework for C code" 1SUMMARY = "Check - unit testing framework for C code"
2DESCRIPTION = "It features a simple interface for defining unit tests, \
3putting little in the way of the developer. Tests are run in a separate \
4address space, so both assertion failures and code errors that cause \
5segmentation faults or other signals can be caught. Test results are \
6reportable in the following: Subunit, TAP, XML, and a generic logging format."
2HOMEPAGE = "https://libcheck.github.io/check/" 7HOMEPAGE = "https://libcheck.github.io/check/"
3SECTION = "devel" 8SECTION = "devel"
4 9
5LICENSE = "LGPLv2.1+" 10LICENSE = "LGPL-2.1-or-later"
6LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1" 11LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
7 12
8SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \ 13SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/check-${PV}.tar.gz \
14 file://automake-output.patch \
9 file://not-echo-compiler-info-to-check_stdint.h.patch" 15 file://not-echo-compiler-info-to-check_stdint.h.patch"
10SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a" 16SRC_URI[sha256sum] = "a8de4e0bacfb4d76dd1c618ded263523b53b85d92a146d8835eb1a52932fa20a"
11UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/" 17GITHUB_BASE_URI = "https://github.com/libcheck/check/releases/"
12 18
13S = "${WORKDIR}/check-${PV}" 19S = "${WORKDIR}/check-${PV}"
14 20
15inherit autotools pkgconfig texinfo 21inherit autotools pkgconfig texinfo github-releases
16 22
17CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk" 23CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
18 24
19RREPLACES_${PN} = "check (<= 0.9.5)" 25RREPLACES:${PN} = "check (<= 0.9.5)"
20 26
27do_install:append:class-native() {
28 create_cmdline_shebang_wrapper ${D}${bindir}/checkmk
29}
21BBCLASSEXTEND = "native nativesdk" 30BBCLASSEXTEND = "native nativesdk"
22 31
23PACKAGES =+ "checkmk" 32PACKAGES =+ "checkmk"
24 33
25FILES_checkmk = "${bindir}/checkmk" 34FILES:checkmk = "${bindir}/checkmk"
26
27RDEPENDS_checkmk = "gawk"
28 35
36RDEPENDS:checkmk = "gawk"