summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcheck/libcheck_0.15.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcheck/libcheck_0.15.0.bb')
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.15.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/libcheck/libcheck_0.15.0.bb b/meta/recipes-support/libcheck/libcheck_0.15.0.bb
new file mode 100644
index 0000000000..177c0edc8f
--- /dev/null
+++ b/meta/recipes-support/libcheck/libcheck_0.15.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Check - unit testing framework for C code"
2HOMEPAGE = "https://libcheck.github.io/check/"
3SECTION = "devel"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
7
8SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \
9 file://not-echo-compiler-info-to-check_stdint.h.patch"
10SRC_URI[sha256sum] = "aea2e3c68fa6e1e92378e744b1c0db350ccda4b6bd0d19530d0ae185b3d1ac60"
11UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/"
12
13S = "${WORKDIR}/check-${PV}"
14
15inherit autotools pkgconfig texinfo
16
17CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
18
19RREPLACES_${PN} = "check (<= 0.9.5)"
20
21BBCLASSEXTEND = "native nativesdk"
22
23PACKAGES =+ "checkmk"
24
25FILES_checkmk = "${bindir}/checkmk"
26
27RDEPENDS_checkmk = "gawk"
28