summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcheck/libcheck_0.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcheck/libcheck_0.14.0.bb')
-rw-r--r--meta/recipes-support/libcheck/libcheck_0.14.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libcheck/libcheck_0.14.0.bb b/meta/recipes-support/libcheck/libcheck_0.14.0.bb
new file mode 100644
index 0000000000..a88f009cdb
--- /dev/null
+++ b/meta/recipes-support/libcheck/libcheck_0.14.0.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Check - unit testing framework for C code"
2HOMEPAGE = "https://libcheck.github.io/check/"
3SECTION = "devel"
4
5LICENSE = "LGPLv2.1+"
6LIC_FILES_CHKSUM = "file://COPYING.LESSER;md5=2d5025d4aa3495befef8f17206a5b0a1"
7
8SRC_URI = "https://github.com/${BPN}/check/releases/download/${PV}/check-${PV}.tar.gz \
9 file://not-echo-compiler-info-to-check_stdint.h.patch"
10SRC_URI[md5sum] = "270e82a445be6026040267a5e11cc94b"
11SRC_URI[sha256sum] = "bd0f0ca1be65b70238b32f8e9fe5d36dc2fbf7a759b7edf28e75323a7d74f30b"
12UPSTREAM_CHECK_URI = "https://github.com/libcheck/check/releases/"
13
14S = "${WORKDIR}/check-${PV}"
15
16inherit autotools pkgconfig texinfo
17
18CACHED_CONFIGUREVARS += "ac_cv_path_AWK_PATH=${bindir}/gawk"
19
20RREPLACES_${PN} = "check (<= 0.9.5)"
21
22BBCLASSEXTEND = "native nativesdk"
23
24PACKAGES =+ "checkmk"
25
26FILES_checkmk = "${bindir}/checkmk"
27
28RDEPENDS_checkmk = "gawk"
29