summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
new file mode 100644
index 0000000000..4790134ae9
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.4.bb
@@ -0,0 +1,29 @@
1require libcap-ng.inc
2
3FILESEXTRAPATHS:prepend := "${THISDIR}/libcap-ng:"
4
5SUMMARY .= " - python"
6
7inherit lib_package autotools python3targetconfig
8
9# drop setuptools when version > 0.8.3 is released; it's needed only for distutils
10DEPENDS += "libcap-ng python3 swig-native python3-setuptools-native"
11
12S = "${WORKDIR}/libcap-ng-${PV}"
13
14EXTRA_OECONF += "--with-python3"
15
16do_install:append() {
17 rm -rf ${D}${bindir}
18 rm -rf ${D}${libdir}/.debug
19 rm -f ${D}${libdir}/lib*
20 rm -rf ${D}${libdir}/pkgconfig
21 rm -rf ${D}${datadir}
22 rm -rf ${D}${includedir}
23}
24
25# PACKAGES = "${PN}"
26
27FILES:${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
28FILES:${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
29