summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
new file mode 100644
index 0000000000..43f76dc561
--- /dev/null
+++ b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
@@ -0,0 +1,29 @@
1require libcap-ng.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
4
5SUMMARY .= " - python"
6
7inherit lib_package autotools python3native
8
9DEPENDS += "libcap-ng python3 swig-native"
10
11S = "${WORKDIR}/libcap-ng-${PV}"
12
13EXTRA_OECONF += "--with-python --with-python3"
14EXTRA_OEMAKE += "PYLIBVER='python${PYTHON_BASEVERSION}${PYTHON_ABI}' PYINC='${STAGING_INCDIR}/${PYLIBVER}'"
15
16do_install_append() {
17 rm -rf ${D}${bindir}
18 rm -rf ${D}${libdir}/.debug
19 rm -f ${D}${libdir}/lib*
20 rm -rf ${D}${libdir}/pkgconfig
21 rm -rf ${D}${datadir}
22 rm -rf ${D}${includedir}
23}
24
25# PACKAGES = "${PN}"
26
27FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
28FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
29