summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb')
-rw-r--r--meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb b/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
deleted file mode 100644
index 6cea422d11..0000000000
--- a/meta/recipes-support/libcap-ng/libcap-ng-python_0.8.2.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1require libcap-ng.inc
2
3FILESEXTRAPATHS_prepend := "${THISDIR}/libcap-ng:"
4
5SUMMARY .= " - python"
6
7inherit lib_package autotools python3targetconfig
8
9DEPENDS += "libcap-ng python3 swig-native"
10
11S = "${WORKDIR}/libcap-ng-${PV}"
12
13EXTRA_OECONF += "--with-python --with-python3"
14
15do_install_append() {
16 rm -rf ${D}${bindir}
17 rm -rf ${D}${libdir}/.debug
18 rm -f ${D}${libdir}/lib*
19 rm -rf ${D}${libdir}/pkgconfig
20 rm -rf ${D}${datadir}
21 rm -rf ${D}${includedir}
22}
23
24# PACKAGES = "${PN}"
25
26FILES_${PN} = "${libdir}/python${PYTHON_BASEVERSION}"
27FILES_${PN}-dbg =+ "${PYTHON_SITEPACKAGES_DIR}/.debug/_capng.so"
28