summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.12.2.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.12.2.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.12.2.bb b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
new file mode 100644
index 0000000000..7d5e88f293
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.12.2.bb
@@ -0,0 +1,47 @@
1SUMMARY = "Library of utility functions from BSD systems"
2DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
3 and lacking on others like GNU systems, thus making it easier to port \
4 projects with strong BSD origins, without needing to embed the same \
5 code over and over again on each project."
6
7HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
8# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
9# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
10# License: BSD-2-clause
11# License: BSD-2-clause-NetBSD
12# License: BSD-2-clause-author
13# License: BSD-2-clause-verbatim
14# License: BSD-3-clause
15# License: BSD-3-clause-author
16# License: BSD-3-clause-John-Birrell
17# License: BSD-3-clause-Regents
18# License: BSD-4-clause-Christopher-G-Demetriou
19# License: BSD-4-clause-Niels-Provos
20# License: BSD-5-clause-Peter-Wemm
21# License: Beerware
22# License: Expat
23# License: ISC
24# License: ISC-Original
25# License: public-domain
26# License: public-domain-Colin-Plumb
27LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
28LICENSE:${PN} = "BSD-3-Clause & ISC & PD"
29LICENSE:${PN}-dbg = "BSD-3-Clause & ISC & PD"
30LICENSE:${PN}-dev = "BSD-3-Clause & ISC & PD"
31LICENSE:${PN}-doc = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
32LICENSE:${PN}-locale = "BSD-3-Clause & ISC & PD"
33LICENSE:${PN}-src = "BSD-3-Clause & ISC & PD"
34LICENSE:${PN}-staticdev = "BSD-3-Clause & ISC & PD"
35
36LIC_FILES_CHKSUM = "file://COPYING;md5=9b087a0981a1fcad42efbba6d4925a0f"
37SECTION = "libs"
38
39SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
40
41SRC_URI[sha256sum] = "b88cc9163d0c652aaf39a99991d974ddba1c3a9711db8f1b5838af2a14731014"
42
43inherit autotools pkgconfig
44
45DEPENDS += "libmd"
46
47BBCLASSEXTEND = "native nativesdk"