summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libbsd/libbsd_0.11.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libbsd/libbsd_0.11.3.bb')
-rw-r--r--meta/recipes-support/libbsd/libbsd_0.11.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-support/libbsd/libbsd_0.11.3.bb b/meta/recipes-support/libbsd/libbsd_0.11.3.bb
new file mode 100644
index 0000000000..55ecae2ea5
--- /dev/null
+++ b/meta/recipes-support/libbsd/libbsd_0.11.3.bb
@@ -0,0 +1,43 @@
1# Copyright (C) 2013 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Library of utility functions from BSD systems"
5DESCRIPTION = "This library provides useful functions commonly found on BSD systems, \
6 and lacking on others like GNU systems, thus making it easier to port \
7 projects with strong BSD origins, without needing to embed the same \
8 code over and over again on each project."
9
10HOMEPAGE = "https://libbsd.freedesktop.org/wiki/"
11# There seems to be more licenses used in the code, I don't think we want to list them all here, complete list:
12# OE @ ~/projects/libbsd $ grep ^License: COPYING | sort -u
13# License: BSD-2-clause
14# License: BSD-2-clause-NetBSD
15# License: BSD-2-clause-author
16# License: BSD-2-clause-verbatim
17# License: BSD-3-clause
18# License: BSD-3-clause-author
19# License: BSD-3-clause-John-Birrell
20# License: BSD-3-clause-Regents
21# License: BSD-4-clause-Christopher-G-Demetriou
22# License: BSD-4-clause-Niels-Provos
23# License: BSD-5-clause-Peter-Wemm
24# License: Beerware
25# License: Expat
26# License: ISC
27# License: ISC-Original
28# License: public-domain
29# License: public-domain-Colin-Plumb
30LICENSE = "BSD-3-Clause & BSD-4-Clause & ISC & PD"
31LICENSE_${PN} = "BSD-3-Clause & ISC & PD"
32LIC_FILES_CHKSUM = "file://COPYING;md5=adf6172075bcc5837e33a8a688eb7e22"
33SECTION = "libs"
34
35SRC_URI = "https://libbsd.freedesktop.org/releases/${BPN}-${PV}.tar.xz"
36
37SRC_URI[sha256sum] = "ff95cf8184151dacae4247832f8d4ea8800fa127dbd15033ecfe839f285b42a1"
38
39inherit autotools pkgconfig
40
41DEPENDS += "libmd"
42
43BBCLASSEXTEND = "native nativesdk"