summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/libassuan/libassuan_2.5.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/libassuan/libassuan_2.5.7.bb')
-rw-r--r--meta/recipes-support/libassuan/libassuan_2.5.7.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/libassuan/libassuan_2.5.7.bb b/meta/recipes-support/libassuan/libassuan_2.5.7.bb
new file mode 100644
index 0000000000..d1e622635f
--- /dev/null
+++ b/meta/recipes-support/libassuan/libassuan_2.5.7.bb
@@ -0,0 +1,38 @@
1SUMMARY = "IPC library used by GnuPG and GPGME"
2DESCRIPTION = "A small library implementing the so-called Assuan protocol. \
3This protocol is used for IPC between most newer GnuPG components. \
4Both, server and client side functions are provided. "
5HOMEPAGE = "http://www.gnupg.org/related_software/libassuan/"
6BUGTRACKER = "https://bugs.g10code.com/gnupg/index"
7
8LICENSE = "GPL-3.0-or-later & LGPL-2.1-or-later"
9LICENSE:${PN} = "LGPL-2.1-or-later"
10LICENSE:${PN}-doc = "GPL-3.0-or-later"
11LIC_FILES_CHKSUM = "file://COPYING;md5=f27defe1e96c2e1ecd4e0c9be8967949 \
12 file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1 \
13 file://src/assuan.c;endline=20;md5=ab92143a5a2adabd06d7994d1467ea5c\
14 file://src/assuan-defs.h;endline=20;md5=15d950c83e82978e35b35e790d7e4d39"
15
16DEPENDS = "libgpg-error"
17
18UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
19SRC_URI = "${GNUPG_MIRROR}/libassuan/libassuan-${PV}.tar.bz2 \
20 file://libassuan-add-pkgconfig-support.patch \
21 "
22
23SRC_URI[sha256sum] = "0103081ffc27838a2e50479153ca105e873d3d65d8a9593282e9c94c7e6afb76"
24
25BINCONFIG = "${bindir}/libassuan-config"
26
27inherit autotools texinfo binconfig-disabled pkgconfig multilib_header
28
29do_configure:prepend () {
30 # Else these could be used in preference to those in aclocal-copy
31 rm -f ${S}/m4/*.m4
32}
33
34do_install:append () {
35 oe_multilib_header assuan.h
36}
37
38BBCLASSEXTEND = "native nativesdk"