summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/itstool/itstool_2.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/itstool/itstool_2.0.7.bb')
-rw-r--r--meta/recipes-support/itstool/itstool_2.0.7.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/itstool/itstool_2.0.7.bb b/meta/recipes-support/itstool/itstool_2.0.7.bb
new file mode 100644
index 0000000000..ddbc49b6cf
--- /dev/null
+++ b/meta/recipes-support/itstool/itstool_2.0.7.bb
@@ -0,0 +1,29 @@
1SUMMARY = "ITS Tool allows you to translate your XML documents with PO files"
2DESCRIPTION = "It extracts messages from XML files and outputs PO template \
3files, then merges translations from MO files to create translated \
4XML files. It determines what to translate and how to chunk it into \
5messages using the W3C Internationalization Tag Set (ITS). "
6HOMEPAGE = "http://itstool.org/"
7LICENSE = "GPL-3.0-only"
8LIC_FILES_CHKSUM = "\
9 file://COPYING;md5=59c57b95fd7d0e9e238ebbc7ad47c5a5 \
10 file://COPYING.GPL3;md5=d32239bcb673463ab874e80d47fae504 \
11"
12
13inherit autotools python3native
14
15DEPENDS = "libxml2-native"
16
17SRC_URI = "http://files.itstool.org/${BPN}/${BPN}-${PV}.tar.bz2 \
18 "
19UPSTREAM_CHECK_URI = "https://itstool.org/download.html"
20
21SRC_URI:append:class-native = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
22SRC_URI:append:class-nativesdk = " file://0001-Native-Don-t-use-build-time-hardcoded-python-binary-.patch"
23SRC_URI:append:class-target = " file://0002-Don-t-use-build-time-hardcoded-python-binary-path.patch"
24
25SRC_URI[sha256sum] = "6b9a7cd29a12bb95598f5750e8763cee78836a1a207f85b74d8b3275b27e87ca"
26
27BBCLASSEXTEND = "native nativesdk"
28
29RDEPENDS:${PN} += "libxml2-python"