summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/icu/icu_69.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/icu/icu_69.1.bb')
-rw-r--r--meta/recipes-support/icu/icu_69.1.bb38
1 files changed, 19 insertions, 19 deletions
diff --git a/meta/recipes-support/icu/icu_69.1.bb b/meta/recipes-support/icu/icu_69.1.bb
index bfeea8d2f0..4daf0fe82e 100644
--- a/meta/recipes-support/icu/icu_69.1.bb
+++ b/meta/recipes-support/icu/icu_69.1.bb
@@ -7,7 +7,7 @@ HOMEPAGE = "http://site.icu-project.org/"
7 7
8LICENSE = "ICU" 8LICENSE = "ICU"
9DEPENDS = "icu-native" 9DEPENDS = "icu-native"
10DEPENDS_class-native = "" 10DEPENDS:class-native = ""
11 11
12CVE_PRODUCT = "international_components_for_unicode" 12CVE_PRODUCT = "international_components_for_unicode"
13 13
@@ -27,15 +27,15 @@ MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/icu-config"
27# cross-compiling. Taken the situation that different builds may share a common sstate-cache 27# cross-compiling. Taken the situation that different builds may share a common sstate-cache
28# into consideration, the native build directory needs to be staged. 28# into consideration, the native build directory needs to be staged.
29EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}" 29EXTRA_OECONF = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
30EXTRA_OECONF_class-native = "" 30EXTRA_OECONF:class-native = ""
31EXTRA_OECONF_class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}" 31EXTRA_OECONF:class-nativesdk = "--with-cross-build=${STAGING_ICU_DIR_NATIVE}"
32 32
33EXTRA_OECONF_append_class-target = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' --with-data-packaging=archive', '', d)}" 33EXTRA_OECONF:append:class-target = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' --with-data-packaging=archive', '', d)}"
34TARGET_CXXFLAGS_append = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' -DICU_DATA_DIR=\\""${datadir}/${BPN}/${PV}\\""', '', d)}" 34TARGET_CXXFLAGS:append = "${@oe.utils.conditional('SITEINFO_ENDIANNESS', 'be', ' -DICU_DATA_DIR=\\""${datadir}/${BPN}/${PV}\\""', '', d)}"
35 35
36ASNEEDED = "" 36ASNEEDED = ""
37 37
38do_compile_prepend_class-target () { 38do_compile:prepend:class-target () {
39 # Make sure certain build host references do not end up being compiled 39 # Make sure certain build host references do not end up being compiled
40 # in the image. This only affects libicutu and icu-dbg 40 # in the image. This only affects libicutu and icu-dbg
41 sed \ 41 sed \
@@ -45,7 +45,7 @@ do_compile_prepend_class-target () {
45} 45}
46 46
47PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}" 47PREPROCESS_RELOCATE_DIRS = "${datadir}/${BPN}/${PV}"
48do_install_append_class-native() { 48do_install:append:class-native() {
49 mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config 49 mkdir -p ${D}/${STAGING_ICU_DIR_NATIVE}/config
50 cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config 50 cp -r ${B}/config/icucross.mk ${D}/${STAGING_ICU_DIR_NATIVE}/config
51 cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config 51 cp -r ${B}/config/icucross.inc ${D}/${STAGING_ICU_DIR_NATIVE}/config
@@ -54,7 +54,7 @@ do_install_append_class-native() {
54 cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE} 54 cp -r ${B}/tools ${D}/${STAGING_ICU_DIR_NATIVE}
55} 55}
56 56
57do_install_append_class-target() { 57do_install:append:class-target() {
58 # The native pkgdata can not generate the correct data file. 58 # The native pkgdata can not generate the correct data file.
59 # Use icupkg to re-generate it. 59 # Use icupkg to re-generate it.
60 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then 60 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
@@ -73,13 +73,13 @@ do_install_append_class-target() {
73 73
74PACKAGES =+ "libicudata libicuuc libicui18n libicutu libicuio" 74PACKAGES =+ "libicudata libicuuc libicui18n libicutu libicuio"
75 75
76FILES_${PN}-dev += "${libdir}/${BPN}/" 76FILES:${PN}-dev += "${libdir}/${BPN}/"
77 77
78FILES_libicudata = "${libdir}/libicudata.so.*" 78FILES:libicudata = "${libdir}/libicudata.so.*"
79FILES_libicuuc = "${libdir}/libicuuc.so.*" 79FILES:libicuuc = "${libdir}/libicuuc.so.*"
80FILES_libicui18n = "${libdir}/libicui18n.so.*" 80FILES:libicui18n = "${libdir}/libicui18n.so.*"
81FILES_libicutu = "${libdir}/libicutu.so.*" 81FILES:libicutu = "${libdir}/libicutu.so.*"
82FILES_libicuio = "${libdir}/libicuio.so.*" 82FILES:libicuio = "${libdir}/libicuio.so.*"
83 83
84BBCLASSEXTEND = "native nativesdk" 84BBCLASSEXTEND = "native nativesdk"
85 85
@@ -97,8 +97,8 @@ ICU_PV = "${@icu_download_version(d)}"
97ICU_FOLDER = "${@icu_download_folder(d)}" 97ICU_FOLDER = "${@icu_download_folder(d)}"
98 98
99# http://errors.yoctoproject.org/Errors/Details/20486/ 99# http://errors.yoctoproject.org/Errors/Details/20486/
100ARM_INSTRUCTION_SET_armv4 = "arm" 100ARM_INSTRUCTION_SET:armv4 = "arm"
101ARM_INSTRUCTION_SET_armv5 = "arm" 101ARM_INSTRUCTION_SET:armv5 = "arm"
102 102
103BASE_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-src.tgz" 103BASE_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-src.tgz"
104DATA_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-data.zip" 104DATA_SRC_URI = "https://github.com/unicode-org/icu/releases/download/release-${ICU_FOLDER}/icu4c-${ICU_PV}-data.zip"
@@ -109,7 +109,7 @@ SRC_URI = "${BASE_SRC_URI};name=code \
109 file://0001-icu-Added-armeb-support.patch \ 109 file://0001-icu-Added-armeb-support.patch \
110 " 110 "
111 111
112SRC_URI_append_class-target = "\ 112SRC_URI:append:class-target = "\
113 file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \ 113 file://0001-Disable-LDFLAGSICUDT-for-Linux.patch \
114 " 114 "
115SRC_URI[code.sha256sum] = "4cba7b7acd1d3c42c44bb0c14be6637098c7faf2b330ce876bc5f3b915d09745" 115SRC_URI[code.sha256sum] = "4cba7b7acd1d3c42c44bb0c14be6637098c7faf2b330ce876bc5f3b915d09745"
@@ -118,12 +118,12 @@ SRC_URI[data.sha256sum] = "4fc2d8cfc3343673123586fca3967404abd4e346fba5515829204
118UPSTREAM_CHECK_REGEX = "icu4c-(?P<pver>\d+(_\d+)+)-src" 118UPSTREAM_CHECK_REGEX = "icu4c-(?P<pver>\d+(_\d+)+)-src"
119UPSTREAM_CHECK_URI = "https://github.com/unicode-org/icu/releases" 119UPSTREAM_CHECK_URI = "https://github.com/unicode-org/icu/releases"
120 120
121EXTRA_OECONF_append_libc-musl = " ac_cv_func_strtod_l=no" 121EXTRA_OECONF:append:libc-musl = " ac_cv_func_strtod_l=no"
122 122
123PACKAGECONFIG ?= "" 123PACKAGECONFIG ?= ""
124PACKAGECONFIG[make-icudata] = ",,," 124PACKAGECONFIG[make-icudata] = ",,,"
125 125
126do_make_icudata_class-target () { 126do_make_icudata:class-target () {
127 ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)} 127 ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
128 cd ${S} 128 cd ${S}
129 rm -rf data 129 rm -rf data