summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls/gnutls_3.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_3.7.1.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.7.1.bb69
1 files changed, 69 insertions, 0 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_3.7.1.bb b/meta/recipes-support/gnutls/gnutls_3.7.1.bb
new file mode 100644
index 0000000000..51d472c828
--- /dev/null
+++ b/meta/recipes-support/gnutls/gnutls_3.7.1.bb
@@ -0,0 +1,69 @@
1SUMMARY = "GNU Transport Layer Security Library"
2DESCRIPTION = "a secure communications library implementing the SSL, \
3TLS and DTLS protocols and technologies around them."
4HOMEPAGE = "https://gnutls.org/"
5BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
6
7LICENSE = "GPLv3+ & LGPLv2.1+"
8LICENSE_${PN} = "LGPLv2.1+"
9LICENSE_${PN}-xx = "LGPLv2.1+"
10LICENSE_${PN}-bin = "GPLv3+"
11LICENSE_${PN}-openssl = "GPLv3+"
12
13LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
14 file://doc/COPYING;md5=c678957b0c8e964aa6c70fd77641a71e \
15 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
16
17DEPENDS = "nettle gmp virtual/libiconv libunistring"
18DEPENDS_append_libc-musl = " argp-standalone"
19
20SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
21
22SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
23 file://arm_eabi.patch \
24 "
25
26SRC_URI[sha256sum] = "3777d7963eca5e06eb315686163b7b3f5045e2baac5e54e038ace9835e5cac6f"
27
28inherit autotools texinfo pkgconfig gettext lib_package gtk-doc
29
30PACKAGECONFIG ??= "libidn"
31
32# You must also have CONFIG_SECCOMP enabled in the kernel for
33# seccomp to work.
34PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
35PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
36PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
37PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
38PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
39
40EXTRA_OECONF = " \
41 --enable-doc \
42 --disable-libdane \
43 --disable-guile \
44 --disable-rpath \
45 --enable-local-libopts \
46 --enable-openssl-compatibility \
47 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
48 --with-librt-prefix=${STAGING_DIR_HOST}${prefix} \
49 --with-default-trust-store-file=${sysconfdir}/ssl/certs/ca-certificates.crt \
50"
51
52# Otherwise the tools try and use HOSTTOOLS_DIR/bash as a shell.
53export POSIX_SHELL="${base_bindir}/sh"
54
55LDFLAGS_append_libc-musl = " -largp"
56
57do_configure_prepend() {
58 for dir in . lib; do
59 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
60 done
61}
62
63PACKAGES =+ "${PN}-openssl ${PN}-xx"
64
65FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
66FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
67FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
68
69BBCLASSEXTEND = "native nativesdk"