summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnutls/gnutls_3.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnutls/gnutls_3.6.3.bb')
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.6.3.bb65
1 files changed, 61 insertions, 4 deletions
diff --git a/meta/recipes-support/gnutls/gnutls_3.6.3.bb b/meta/recipes-support/gnutls/gnutls_3.6.3.bb
index c560305032..dcb211e8e0 100644
--- a/meta/recipes-support/gnutls/gnutls_3.6.3.bb
+++ b/meta/recipes-support/gnutls/gnutls_3.6.3.bb
@@ -1,10 +1,67 @@
1require gnutls.inc 1SUMMARY = "GNU Transport Layer Security Library"
2HOMEPAGE = "http://www.gnu.org/software/gnutls/"
3BUGTRACKER = "https://savannah.gnu.org/support/?group=gnutls"
2 4
3SRC_URI += "file://0001-configure.ac-fix-sed-command.patch \ 5LICENSE = "GPLv3+ & LGPLv2.1+"
4 file://arm_eabi.patch \ 6LICENSE_${PN} = "LGPLv2.1+"
5 " 7LICENSE_${PN}-xx = "LGPLv2.1+"
8LICENSE_${PN}-bin = "GPLv3+"
9LICENSE_${PN}-openssl = "GPLv3+"
10
11LIC_FILES_CHKSUM = "file://LICENSE;md5=71391c8e0c1cfe68077e7fce3b586283 \
12 file://doc/COPYING;md5=d32239bcb673463ab874e80d47fae504 \
13 file://doc/COPYING.LESSER;md5=a6f89e2100d9b6cdffcea4f398e37343"
14
15DEPENDS = "nettle gmp virtual/libiconv libunistring"
16DEPENDS_append_libc-musl = " argp-standalone"
17
18SHRT_VER = "${@d.getVar('PV').split('.')[0]}.${@d.getVar('PV').split('.')[1]}"
19
20SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar.xz \
21 file://0001-configure.ac-fix-sed-command.patch \
22 file://arm_eabi.patch \
23"
6 24
7SRC_URI[md5sum] = "d3b1b05c2546b80832101a423a80faf8" 25SRC_URI[md5sum] = "d3b1b05c2546b80832101a423a80faf8"
8SRC_URI[sha256sum] = "ed642b66a4ecf4851ab2d809cd1475c297b6201d8e8bd14b4d1c08b53ffca993" 26SRC_URI[sha256sum] = "ed642b66a4ecf4851ab2d809cd1475c297b6201d8e8bd14b4d1c08b53ffca993"
9 27
28inherit autotools texinfo binconfig pkgconfig gettext lib_package gtk-doc
29
30PACKAGECONFIG ??= "libidn"
31
32# You must also have CONFIG_SECCOMP enabled in the kernel for
33# seccomp to work.
34PACKAGECONFIG[seccomp] = "ac_cv_libseccomp=yes,ac_cv_libseccomp=no,libseccomp"
35PACKAGECONFIG[libidn] = "--with-idn,--without-idn,libidn2"
36PACKAGECONFIG[libtasn1] = "--with-included-libtasn1=no,--with-included-libtasn1,libtasn1"
37PACKAGECONFIG[p11-kit] = "--with-p11-kit,--without-p11-kit,p11-kit"
38PACKAGECONFIG[tpm] = "--with-tpm,--without-tpm,trousers"
39PACKAGECONFIG[ssl3] = "--enable-ssl3-support,--disable-ssl3-support,"
40PACKAGECONFIG[tls13] = "--enable-tls13-support,--disable-tls13-support,"
41
42EXTRA_OECONF = " \
43 --enable-doc \
44 --disable-libdane \
45 --disable-guile \
46 --disable-rpath \
47 --enable-local-libopts \
48 --enable-openssl-compatibility \
49 --with-libpthread-prefix=${STAGING_DIR_HOST}${prefix} \
50 --without-libunistring-prefix \
51"
52
53LDFLAGS_append_libc-musl = " -largp"
54
55do_configure_prepend() {
56 for dir in . lib; do
57 rm -f ${dir}/aclocal.m4 ${dir}/m4/libtool.m4 ${dir}/m4/lt*.m4
58 done
59}
60
61PACKAGES =+ "${PN}-openssl ${PN}-xx"
62
63FILES_${PN}-dev += "${bindir}/gnutls-cli-debug"
64FILES_${PN}-openssl = "${libdir}/libgnutls-openssl.so.*"
65FILES_${PN}-xx = "${libdir}/libgnutlsxx.so.*"
66
10BBCLASSEXTEND = "native nativesdk" 67BBCLASSEXTEND = "native nativesdk"