summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.4.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.4.5.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.4.5.bb90
1 files changed, 90 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.4.5.bb b/meta/recipes-support/gnupg/gnupg_2.4.5.bb
new file mode 100644
index 0000000000..99996968b1
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.4.5.bb
@@ -0,0 +1,90 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2DESCRIPTION = "A complete and free implementation of the OpenPGP standard \
3as defined by RFC4880 (also known as PGP). GnuPG allows you to encrypt \
4and sign your data and communications; it features a versatile key \
5management system, along with access modules for all kinds of public \
6key directories."
7HOMEPAGE = "http://www.gnupg.org/"
8LICENSE = "GPL-3.0-only & LGPL-3.0-only"
9LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
10 file://COPYING.LGPL3;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
11
12DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
13
14inherit autotools gettext texinfo pkgconfig
15
16UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
17SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
18 file://0002-use-pkgconfig-instead-of-npth-config.patch \
19 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
20 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
21 "
22SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
23 file://relocate.patch"
24SRC_URI:append:class-nativesdk = " file://relocate.patch"
25
26SRC_URI[sha256sum] = "f68f7d75d06cb1635c336d34d844af97436c3f64ea14bcb7c869782f96f44277"
27
28EXTRA_OECONF = "--disable-ldap \
29 --disable-ccid-driver \
30 --with-zlib=${STAGING_LIBDIR}/.. \
31 --with-bzip2=${STAGING_LIBDIR}/.. \
32 --with-readline=${STAGING_LIBDIR}/.. \
33 --with-mailprog=${sbindir}/sendmail \
34 --enable-gpg-is-gpg2 \
35 --disable-tests \
36 "
37# yat2m can be found from recipe-sysroot-native non-deterministically with different versioning otherwise
38CACHED_CONFIGUREVARS += "ac_cv_path_YAT2M=./yat2m"
39
40# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
41PACKAGES =+ "${PN}-gpg"
42FILES:${PN}-gpg = " \
43 ${bindir}/gpg \
44 ${bindir}/gpg2 \
45 ${bindir}/gpg-agent \
46"
47
48# Normal package (gnupg) should depend on minimal package (gnupg-gpg)
49# to ensure all tools are included. This is done only in non-native
50# builds. Native builds don't have sub-packages, so appending RDEPENDS
51# in this case breaks recipe parsing.
52RDEPENDS:${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
53
54RRECOMMENDS:${PN} = "pinentry"
55
56do_configure:prepend () {
57 # Else these could be used in prefernce to those in aclocal-copy
58 rm -f ${S}/m4/gpg-error.m4
59 rm -f ${S}/m4/libassuan.m4
60 rm -f ${S}/m4/ksba.m4
61 rm -f ${S}/m4/libgcrypt.m4
62}
63
64do_install:append() {
65 ln -sf gpg2 ${D}${bindir}/gpg
66 ln -sf gpgv2 ${D}${bindir}/gpgv
67}
68
69do_install:append:class-native() {
70 create_wrappers ${STAGING_BINDIR_NATIVE}
71}
72
73do_install:append:class-nativesdk() {
74 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
75}
76
77create_wrappers() {
78 for i in gpg2 gpgconf gpg-agent gpg-connect-agent; do
79 create_wrapper ${D}${bindir}/$i GNUPG_BINDIR=$1
80 done
81}
82
83PACKAGECONFIG ??= "gnutls"
84PACKAGECONFIG[gnutls] = "--enable-gnutls, --disable-gnutls, gnutls"
85PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"
86
87BBCLASSEXTEND = "native nativesdk"
88
89lcl_maybe_fortify:mipsarch = ""
90