summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.3.1.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.3.1.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.3.1.bb b/meta/recipes-support/gnupg/gnupg_2.3.1.bb
index 77331efc0b..b8b0314d2f 100644
--- a/meta/recipes-support/gnupg/gnupg_2.3.1.bb
+++ b/meta/recipes-support/gnupg/gnupg_2.3.1.bb
@@ -20,9 +20,9 @@ SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
20 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \ 20 file://0004-autogen.sh-fix-find-version-for-beta-checking.patch \
21 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \ 21 file://0001-Woverride-init-is-not-needed-with-gcc-9.patch \
22 " 22 "
23SRC_URI_append_class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \ 23SRC_URI:append:class-native = " file://0001-configure.ac-use-a-custom-value-for-the-location-of-.patch \
24 file://relocate.patch" 24 file://relocate.patch"
25SRC_URI_append_class-nativesdk = " file://relocate.patch" 25SRC_URI:append:class-nativesdk = " file://relocate.patch"
26 26
27SRC_URI[sha256sum] = "c498db346a9b9a4b399e514c8f56dfc0a888ce8f327f10376ff984452cd154ec" 27SRC_URI[sha256sum] = "c498db346a9b9a4b399e514c8f56dfc0a888ce8f327f10376ff984452cd154ec"
28 28
@@ -36,7 +36,7 @@ EXTRA_OECONF = "--disable-ldap \
36 36
37# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg) 37# A minimal package containing just enough to run gpg+gpgagent (E.g. use gpgme in opkg)
38PACKAGES =+ "${PN}-gpg" 38PACKAGES =+ "${PN}-gpg"
39FILES_${PN}-gpg = " \ 39FILES:${PN}-gpg = " \
40 ${bindir}/gpg \ 40 ${bindir}/gpg \
41 ${bindir}/gpg2 \ 41 ${bindir}/gpg2 \
42 ${bindir}/gpg-agent \ 42 ${bindir}/gpg-agent \
@@ -46,11 +46,11 @@ FILES_${PN}-gpg = " \
46# to ensure all tools are included. This is done only in non-native 46# to ensure all tools are included. This is done only in non-native
47# builds. Native builds don't have sub-packages, so appending RDEPENDS 47# builds. Native builds don't have sub-packages, so appending RDEPENDS
48# in this case breaks recipe parsing. 48# in this case breaks recipe parsing.
49RDEPENDS_${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}" 49RDEPENDS:${PN} += "${@ "" if ("native" in d.getVar("PN")) else (d.getVar("PN") + "-gpg")}"
50 50
51RRECOMMENDS_${PN} = "pinentry" 51RRECOMMENDS:${PN} = "pinentry"
52 52
53do_configure_prepend () { 53do_configure:prepend () {
54 # Else these could be used in prefernce to those in aclocal-copy 54 # Else these could be used in prefernce to those in aclocal-copy
55 rm -f ${S}/m4/gpg-error.m4 55 rm -f ${S}/m4/gpg-error.m4
56 rm -f ${S}/m4/libassuan.m4 56 rm -f ${S}/m4/libassuan.m4
@@ -58,16 +58,16 @@ do_configure_prepend () {
58 rm -f ${S}/m4/libgcrypt.m4 58 rm -f ${S}/m4/libgcrypt.m4
59} 59}
60 60
61do_install_append() { 61do_install:append() {
62 ln -sf gpg2 ${D}${bindir}/gpg 62 ln -sf gpg2 ${D}${bindir}/gpg
63 ln -sf gpgv2 ${D}${bindir}/gpgv 63 ln -sf gpgv2 ${D}${bindir}/gpgv
64} 64}
65 65
66do_install_append_class-native() { 66do_install:append:class-native() {
67 create_wrappers ${STAGING_BINDIR_NATIVE} 67 create_wrappers ${STAGING_BINDIR_NATIVE}
68} 68}
69 69
70do_install_append_class-nativesdk() { 70do_install:append:class-nativesdk() {
71 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk} 71 create_wrappers ${SDKPATHNATIVE}${bindir_nativesdk}
72} 72}
73 73