summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gnupg/gnupg_2.1.18.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gnupg/gnupg_2.1.18.bb')
-rw-r--r--meta/recipes-support/gnupg/gnupg_2.1.18.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-support/gnupg/gnupg_2.1.18.bb b/meta/recipes-support/gnupg/gnupg_2.1.18.bb
new file mode 100644
index 0000000000..a0611aa007
--- /dev/null
+++ b/meta/recipes-support/gnupg/gnupg_2.1.18.bb
@@ -0,0 +1,46 @@
1SUMMARY = "GNU Privacy Guard - encryption and signing tools (2.x)"
2HOMEPAGE = "http://www.gnupg.org/"
3LICENSE = "GPLv3 & LGPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=189af8afca6d6075ba6c9e0aa8077626 \
5 file://COPYING.LIB;md5=a2b6bf2cb38ee52619e60f30a1fc7257"
6
7DEPENDS = "npth libassuan libksba zlib bzip2 readline libgcrypt"
8
9inherit autotools gettext texinfo pkgconfig
10
11UPSTREAM_CHECK_URI = "https://gnupg.org/download/index.html"
12SRC_URI = "${GNUPG_MIRROR}/${BPN}/${BPN}-${PV}.tar.bz2 \
13 file://pkgconfig.patch \
14 file://use-pkgconfig-instead-of-npth-config.patch \
15 file://dirmngr-uses-libgpg-error.patch \
16 file://autogen.sh-fix-find-version-for-beta-checking.patch \
17 "
18
19SRC_URI[md5sum] = "c67f908b0b35c7ebc62144f362757e1e"
20SRC_URI[sha256sum] = "d04c6fab7e5562ce4b915b22020e34d4c1a256847690cf149842264fc7cef994"
21
22EXTRA_OECONF = "--disable-ldap \
23 --disable-ccid-driver \
24 --with-zlib=${STAGING_LIBDIR}/.. \
25 --with-bzip2=${STAGING_LIBDIR}/.. \
26 --with-readline=${STAGING_LIBDIR}/.. \
27 "
28RRECOMMENDS_${PN} = "pinentry"
29
30do_configure_prepend () {
31 # Else these could be used in prefernce to those in aclocal-copy
32 rm -f ${S}/m4/gpg-error.m4
33 rm -f ${S}/m4/libassuan.m4
34 rm -f ${S}/m4/ksba.m4
35 rm -f ${S}/m4/libgcrypt.m4
36}
37
38do_install_append() {
39 ln -sf gpg2 ${D}${bindir}/gpg
40 ln -sf gpgv2 ${D}${bindir}/gpgv
41}
42
43RDEPENDS_${PN} = "gnutls"
44
45PACKAGECONFIG ??= ""
46PACKAGECONFIG[sqlite3] = "--enable-sqlite, --disable-sqlite, sqlite3"