summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/gdbm/gdbm_1.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/gdbm/gdbm_1.10.bb')
-rw-r--r--meta/recipes-support/gdbm/gdbm_1.10.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta/recipes-support/gdbm/gdbm_1.10.bb b/meta/recipes-support/gdbm/gdbm_1.10.bb
deleted file mode 100644
index c031f4a6b5..0000000000
--- a/meta/recipes-support/gdbm/gdbm_1.10.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "Key/value database library with extensible hashing"
2HOMEPAGE = "http://www.gnu.org/software/gdbm/"
3SECTION = "libs"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=241da1b9fe42e642cbb2c24d5e0c4d24"
6
7PR = "r3"
8
9SRC_URI = "${GNU_MIRROR}/gdbm/gdbm-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "88770493c2559dc80b561293e39d3570"
12SRC_URI[sha256sum] = "23f8134c5b94bbfb06d756a6b78f074fba6e6028cf2fe01341d40b26db773441"
13
14inherit autotools gettext lib_package
15
16# Needed for dbm python module
17EXTRA_OECONF = "-enable-libgdbm-compat"
18
19# Stop presence of dbm/nbdm on the host contaminating builds
20CACHED_CONFIGUREVARS += "ac_cv_lib_ndbm_main=no ac_cv_lib_dbm_main=no"
21
22BBCLASSEXTEND = "native nativesdk"
23
24do_install_append () {
25 # Create a symlink to ndbm.h and gdbm.h in include/gdbm to let other packages to find
26 # these headers
27 install -d ${D}${includedir}/gdbm
28 ln -sf ../ndbm.h ${D}/${includedir}/gdbm/ndbm.h
29 ln -sf ../gdbm.h ${D}/${includedir}/gdbm/gdbm.h
30}
31
32PACKAGES =+ "${PN}-compat \
33 "
34FILES_${PN}-compat = "${libdir}/libgdbm_compat${SOLIBS} \
35 "