summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/enchant/enchant2_2.2.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/enchant/enchant2_2.2.13.bb')
-rw-r--r--meta/recipes-support/enchant/enchant2_2.2.13.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/enchant/enchant2_2.2.13.bb b/meta/recipes-support/enchant/enchant2_2.2.13.bb
new file mode 100644
index 0000000000..3b890e733a
--- /dev/null
+++ b/meta/recipes-support/enchant/enchant2_2.2.13.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Enchant Spell checker API Library"
2SECTION = "libs"
3HOMEPAGE = "https://abiword.github.io/enchant/"
4LICENSE = "LGPLv2.1+"
5LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=4fbd65380cdd255951079008b364516c"
6
7DEPENDS = "glib-2.0"
8
9inherit autotools pkgconfig
10
11SRC_URI = "https://github.com/AbiWord/enchant/releases/download/v${PV}/enchant-${PV}.tar.gz"
12SRC_URI[sha256sum] = "eab9f90d79039133660029616e2a684644bd524be5dc43340d4cfc3fb3c68a20"
13
14UPSTREAM_CHECK_URI = "https://github.com/AbiWord/enchant/releases"
15
16S = "${WORKDIR}/enchant-${PV}"
17
18EXTRA_OEMAKE = "pkgdatadir=${datadir}/enchant-2"
19
20PACKAGECONFIG ??= "aspell"
21PACKAGECONFIG[aspell] = "--with-aspell,--without-aspell,aspell,aspell"
22PACKAGECONFIG[hunspell] = "--with-hunspell,--without-hunspell,hunspell,hunspell"
23
24FILES_${PN} += " \
25 ${datadir}/enchant-2 \
26 ${libdir}/enchant-2 \
27"
28FILES_${PN}-staticdev += "${libdir}/enchant-2/*.a"