summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/diffoscope/diffoscope_168.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/diffoscope/diffoscope_168.bb')
-rw-r--r--meta/recipes-support/diffoscope/diffoscope_168.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta/recipes-support/diffoscope/diffoscope_168.bb b/meta/recipes-support/diffoscope/diffoscope_168.bb
deleted file mode 100644
index 9d112d2ce8..0000000000
--- a/meta/recipes-support/diffoscope/diffoscope_168.bb
+++ /dev/null
@@ -1,24 +0,0 @@
1SUMMARY = "in-depth comparison of files, archives, and directories"
2HOMEPAGE = "https://diffoscope.org/"
3LICENSE = "GPL-3.0+"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5
6PYPI_PACKAGE = "diffoscope"
7
8inherit pypi setuptools3
9
10SRC_URI[sha256sum] = "c6f1dc3e75b7e2e5ceac4f857fbd2ee0ddb3f0169c2b39ea9187af34208e98de"
11
12RDEPENDS_${PN} += "binutils vim squashfs-tools python3-libarchive-c python3-magic python3-rpm"
13
14# Dependencies don't build for musl
15COMPATIBLE_HOST_libc-musl = 'null'
16
17do_install_append_class-native() {
18 create_wrapper ${D}${bindir}/diffoscope \
19 MAGIC=${STAGING_DIR_NATIVE}${datadir_native}/misc/magic.mgc \
20 RPM_CONFIGDIR=${STAGING_LIBDIR_NATIVE}/rpm \
21 RPM_ETCCONFIGDIR=${STAGING_DIR_NATIVE}
22}
23
24BBCLASSEXTEND = "native"