summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.84.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.84.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.84.0.bb96
1 files changed, 96 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.84.0.bb b/meta/recipes-support/curl/curl_7.84.0.bb
new file mode 100644
index 0000000000..74a19d20c9
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.84.0.bb
@@ -0,0 +1,96 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2DESCRIPTION = "It uses URL syntax to transfer data to and from servers. \
3curl is a widely used because of its ability to be flexible and complete \
4complex tasks. For example, you can use curl for things like user authentication, \
5HTTP post, SSL connections, proxy support, FTP uploads, and more!"
6HOMEPAGE = "https://curl.se/"
7BUGTRACKER = "https://github.com/curl/curl/issues"
8SECTION = "console/network"
9LICENSE = "MIT-open-group"
10LIC_FILES_CHKSUM = "file://COPYING;md5=190c514872597083303371684954f238"
11
12SRC_URI = " \
13 https://curl.se/download/${BP}.tar.xz \
14 file://0001-easy_lock.h-include-sched.h-if-available-to-fix-buil.patch \
15"
16SRC_URI[sha256sum] = "2d118b43f547bfe5bae806d8d47b4e596ea5b25a6c1f080aef49fbcd817c5db8"
17
18# Curl has used many names over the years...
19CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl"
20
21inherit autotools pkgconfig binconfig multilib_header
22
23# Entropy source for random PACKAGECONFIG option
24RANDOM ?= "/dev/urandom"
25
26PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} libidn openssl proxy random threaded-resolver verbose zlib"
27PACKAGECONFIG:class-native = "ipv6 openssl proxy random threaded-resolver verbose zlib"
28PACKAGECONFIG:class-nativesdk = "ipv6 openssl proxy random threaded-resolver verbose zlib"
29
30# 'ares' and 'threaded-resolver' are mutually exclusive
31PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
32PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
33PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
34PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
35PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
36PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
37PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
38PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
39PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
40PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
41PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
42PACKAGECONFIG[libgsasl] = "--with-libgsasl,--without-libgsasl,libgsasl"
43PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
44PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
45PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
46PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
47PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
48PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl"
49PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
50PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
51PACKAGECONFIG[random] = "--with-random=${RANDOM},--without-random"
52PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
53PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
54PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
55PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
56PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
57PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
58PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
59PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares"
60PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
61PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
62PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
63
64EXTRA_OECONF = " \
65 --disable-libcurl-option \
66 --disable-ntlm-wb \
67 --enable-crypto-auth \
68 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
69 --without-libpsl \
70 --enable-debug \
71 --enable-optimize \
72 --disable-curldebug \
73 ${@'--without-ssl' if (bb.utils.filter('PACKAGECONFIG', 'gnutls mbedtls nss openssl', d) == '') else ''} \
74"
75
76do_install:append:class-target() {
77 # cleanup buildpaths from curl-config
78 sed -i \
79 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
80 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
81 -e 's|${DEBUG_PREFIX_MAP}||g' \
82 -e 's|${@" ".join(d.getVar("DEBUG_PREFIX_MAP").split())}||g' \
83 ${D}${bindir}/curl-config
84}
85
86PACKAGES =+ "lib${BPN}"
87
88FILES:lib${BPN} = "${libdir}/lib*.so.*"
89RRECOMMENDS:lib${BPN} += "ca-certificates"
90
91FILES:${PN} += "${datadir}/zsh"
92
93inherit multilib_script
94MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
95
96BBCLASSEXTEND = "native nativesdk"