summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.81.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.81.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.81.0.bb88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.81.0.bb b/meta/recipes-support/curl/curl_7.81.0.bb
new file mode 100644
index 0000000000..30bd928751
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.81.0.bb
@@ -0,0 +1,88 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2DESCRIPTION = "It uses URL syntax to transfer data to and from servers. \
3curl is a widely used because of its ability to be flexible and complete \
4complex tasks. For example, you can use curl for things like user authentication, \
5HTTP post, SSL connections, proxy support, FTP uploads, and more!"
6HOMEPAGE = "https://curl.se/"
7BUGTRACKER = "https://github.com/curl/curl/issues"
8SECTION = "console/network"
9LICENSE = "MIT"
10LIC_FILES_CHKSUM = "file://COPYING;md5=425f6fdc767cc067518eef9bbdf4ab7b"
11
12SRC_URI = "https://curl.se/download/${BP}.tar.xz"
13SRC_URI[sha256sum] = "a067b688d1645183febc31309ec1f3cdce9213d02136b6a6de3d50f69c95a7d3"
14
15# Curl has used many names over the years...
16CVE_PRODUCT = "haxx:curl haxx:libcurl curl:curl curl:libcurl libcurl:libcurl daniel_stenberg:curl"
17
18inherit autotools pkgconfig binconfig multilib_header
19
20PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} ssl libidn proxy threaded-resolver verbose zlib"
21PACKAGECONFIG:class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
22PACKAGECONFIG:class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
23
24# 'ares' and 'threaded-resolver' are mutually exclusive
25PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares,,,threaded-resolver"
26PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
27PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
28PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
29PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
30PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
31PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
32PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
33PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
34PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
35PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
36PACKAGECONFIG[libgsasl] = "--with-libgsasl,--without-libgsasl,libgsasl"
37PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
38PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
39PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
40PACKAGECONFIG[mqtt] = "--enable-mqtt,--disable-mqtt,"
41PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
42PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
43PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
44PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
45PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
46PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
47PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
48PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
49PACKAGECONFIG[nss] = "--with-nss,--without-nss,nss"
50PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
51PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
52PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver,,,,ares"
53PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
54PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
55PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd"
56
57EXTRA_OECONF = " \
58 --disable-libcurl-option \
59 --disable-ntlm-wb \
60 --enable-crypto-auth \
61 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
62 --without-libpsl \
63 --enable-debug \
64 --enable-optimize \
65 --disable-curldebug \
66"
67
68do_install:append:class-target() {
69 # cleanup buildpaths from curl-config
70 sed -i \
71 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
72 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
73 -e 's|${DEBUG_PREFIX_MAP}||g' \
74 -e 's|${@" ".join(d.getVar("DEBUG_PREFIX_MAP").split())}||g' \
75 ${D}${bindir}/curl-config
76}
77
78PACKAGES =+ "lib${BPN}"
79
80FILES:lib${BPN} = "${libdir}/lib*.so.*"
81RRECOMMENDS:lib${BPN} += "ca-certificates"
82
83FILES:${PN} += "${datadir}/zsh"
84
85inherit multilib_script
86MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
87
88BBCLASSEXTEND = "native nativesdk"