summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.62.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.62.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.62.0.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.62.0.bb b/meta/recipes-support/curl/curl_7.62.0.bb
new file mode 100644
index 0000000000..2baab2b503
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.62.0.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;md5=ef889a37a5a874490ac7ce116396f29a"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
12SRC_URI[md5sum] = "7adf426f80c68bbdd04d44b9bc171d61"
13SRC_URI[sha256sum] = "7802c54076500be500b171fde786258579d60547a3a35b8c5a23d8c88e8f9620"
14
15CVE_PRODUCT = "curl libcurl"
16inherit autotools pkgconfig binconfig multilib_header
17
18PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls libidn proxy threaded-resolver verbose zlib"
19PACKAGECONFIG_class-native = "ipv6 proxy ssl threaded-resolver verbose zlib"
20PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl threaded-resolver verbose zlib"
21
22# 'ares' and 'threaded-resolver' are mutually exclusive
23PACKAGECONFIG[ares] = "--enable-ares,--disable-ares,c-ares"
24PACKAGECONFIG[brotli] = "--with-brotli,--without-brotli,brotli"
25PACKAGECONFIG[builtinmanual] = "--enable-manual,--disable-manual"
26PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
27PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
28PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
29PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
30PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
31PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
32PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
33PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
34PACKAGECONFIG[libidn] = "--with-libidn2,--without-libidn2,libidn2"
35PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
36PACKAGECONFIG[mbedtls] = "--with-mbedtls=${STAGING_DIR_TARGET},--without-mbedtls,mbedtls"
37PACKAGECONFIG[nghttp2] = "--with-nghttp2,--without-nghttp2,nghttp2"
38PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
39PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
40PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
41PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
42PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
43PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
44PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
45PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
46PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
47PACKAGECONFIG[threaded-resolver] = "--enable-threaded-resolver,--disable-threaded-resolver"
48PACKAGECONFIG[verbose] = "--enable-verbose,--disable-verbose"
49PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
50
51EXTRA_OECONF = " \
52 --disable-libcurl-option \
53 --disable-ntlm-wb \
54 --enable-crypto-auth \
55 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
56 --without-libmetalink \
57 --without-libpsl \
58"
59
60do_install_append_class-target() {
61 # cleanup buildpaths from curl-config
62 sed -i \
63 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
64 -e 's,--with-libtool-sysroot=${STAGING_DIR_TARGET},,g' \
65 -e 's|${DEBUG_PREFIX_MAP}||g' \
66 ${D}${bindir}/curl-config
67}
68
69PACKAGES =+ "lib${BPN}"
70
71FILES_lib${BPN} = "${libdir}/lib*.so.*"
72RRECOMMENDS_lib${BPN} += "ca-certificates"
73
74FILES_${PN} += "${datadir}/zsh"
75
76inherit multilib_script
77MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/curl-config"
78
79BBCLASSEXTEND = "native nativesdk"