summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/curl/curl_7.53.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/curl/curl_7.53.0.bb')
-rw-r--r--meta/recipes-support/curl/curl_7.53.0.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.53.0.bb b/meta/recipes-support/curl/curl_7.53.0.bb
new file mode 100644
index 0000000000..a4cca1572a
--- /dev/null
+++ b/meta/recipes-support/curl/curl_7.53.0.bb
@@ -0,0 +1,72 @@
1SUMMARY = "Command line tool and library for client-side URL transfers"
2HOMEPAGE = "http://curl.haxx.se/"
3BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker"
4SECTION = "console/network"
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://COPYING;beginline=8;md5=3a34942f4ae3fbf1a303160714e664ac"
7
8SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \
9 file://0001-replace-krb5-config-with-pkg-config.patch \
10"
11
12# curl likes to set -g0 in CFLAGS, so we stop it
13# from mucking around with debug options
14#
15SRC_URI += " file://configure_ac.patch"
16
17SRC_URI[md5sum] = "ede199c63b84df39f42da9da68de85c5"
18SRC_URI[sha256sum] = "b2345a8bef87b4c229dedf637cb203b5e21db05e20277c8e1094f0d4da180801"
19
20CVE_PRODUCT = "libcurl"
21inherit autotools pkgconfig binconfig multilib_header
22
23PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)} gnutls proxy zlib"
24PACKAGECONFIG_class-native = "ipv6 proxy ssl zlib"
25PACKAGECONFIG_class-nativesdk = "ipv6 proxy ssl zlib"
26
27PACKAGECONFIG[dict] = "--enable-dict,--disable-dict,"
28PACKAGECONFIG[gnutls] = "--with-gnutls,--without-gnutls,gnutls"
29PACKAGECONFIG[gopher] = "--enable-gopher,--disable-gopher,"
30PACKAGECONFIG[imap] = "--enable-imap,--disable-imap,"
31PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
32PACKAGECONFIG[ldap] = "--enable-ldap,--disable-ldap,"
33PACKAGECONFIG[ldaps] = "--enable-ldaps,--disable-ldaps,"
34PACKAGECONFIG[libidn] = "--with-libidn,--without-libidn,libidn"
35PACKAGECONFIG[libssh2] = "--with-libssh2,--without-libssh2,libssh2"
36PACKAGECONFIG[pop3] = "--enable-pop3,--disable-pop3,"
37PACKAGECONFIG[proxy] = "--enable-proxy,--disable-proxy,"
38PACKAGECONFIG[rtmpdump] = "--with-librtmp,--without-librtmp,rtmpdump"
39PACKAGECONFIG[rtsp] = "--enable-rtsp,--disable-rtsp,"
40PACKAGECONFIG[smb] = "--enable-smb,--disable-smb,"
41PACKAGECONFIG[smtp] = "--enable-smtp,--disable-smtp,"
42PACKAGECONFIG[ssl] = "--with-ssl --with-random=/dev/urandom,--without-ssl,openssl"
43PACKAGECONFIG[telnet] = "--enable-telnet,--disable-telnet,"
44PACKAGECONFIG[tftp] = "--enable-tftp,--disable-tftp,"
45PACKAGECONFIG[zlib] = "--with-zlib=${STAGING_LIBDIR}/../,--without-zlib,zlib"
46PACKAGECONFIG[krb5] = "--with-gssapi,--without-gssapi,krb5"
47
48EXTRA_OECONF = " \
49 --enable-crypto-auth \
50 --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \
51 --without-libmetalink \
52 --without-libpsl \
53 --without-nghttp2 \
54"
55
56do_install_append() {
57 oe_multilib_header curl/curlbuild.h
58}
59
60do_install_append_class-target() {
61 # cleanup buildpaths from curl-config
62 sed -i -e 's,${STAGING_DIR_HOST},,g' ${D}${bindir}/curl-config
63}
64
65PACKAGES =+ "lib${BPN}"
66
67FILES_lib${BPN} = "${libdir}/lib*.so.*"
68RRECOMMENDS_lib${BPN} += "ca-certificates"
69
70FILES_${PN} += "${datadir}/zsh"
71
72BBCLASSEXTEND = "native nativesdk"