diff options
Diffstat (limited to 'meta/recipes-support/curl/curl_7.36.0.bb')
-rw-r--r-- | meta/recipes-support/curl/curl_7.36.0.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-support/curl/curl_7.36.0.bb b/meta/recipes-support/curl/curl_7.36.0.bb new file mode 100644 index 0000000000..6f5546321a --- /dev/null +++ b/meta/recipes-support/curl/curl_7.36.0.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "Command line tool and library for client-side URL transfers" | ||
2 | HOMEPAGE = "http://curl.haxx.se/" | ||
3 | BUGTRACKER = "http://curl.haxx.se/mail/list.cgi?list=curl-tracker" | ||
4 | SECTION = "console/network" | ||
5 | LICENSE = "MIT" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;beginline=7;md5=3a34942f4ae3fbf1a303160714e664ac" | ||
7 | |||
8 | DEPENDS = "zlib gnutls" | ||
9 | DEPENDS_class-native = "zlib-native openssl-native" | ||
10 | DEPENDS_class-nativesdk = "nativesdk-zlib" | ||
11 | |||
12 | SRC_URI = "http://curl.haxx.se/download/curl-${PV}.tar.bz2 \ | ||
13 | file://pkgconfig_fix.patch \ | ||
14 | " | ||
15 | |||
16 | # curl likes to set -g0 in CFLAGS, so we stop it | ||
17 | # from mucking around with debug options | ||
18 | # | ||
19 | SRC_URI += " file://configure_ac.patch" | ||
20 | |||
21 | SRC_URI[md5sum] = "e6d1f9d1b59da5062109ffe14e0569a4" | ||
22 | SRC_URI[sha256sum] = "1fbe82b89bcd6b7ccda8cb0ff076edc60e911595030e27689f4abd5ef7f3cfcd" | ||
23 | |||
24 | inherit autotools pkgconfig binconfig multilib_header | ||
25 | |||
26 | EXTRA_OECONF = "--with-zlib=${STAGING_LIBDIR}/../ \ | ||
27 | --without-libssh2 \ | ||
28 | --with-random=/dev/urandom \ | ||
29 | --without-libidn \ | ||
30 | --enable-crypto-auth \ | ||
31 | --disable-ldap \ | ||
32 | --disable-ldaps \ | ||
33 | --with-ca-bundle=${sysconfdir}/ssl/certs/ca-certificates.crt \ | ||
34 | ${CURLGNUTLS} \ | ||
35 | " | ||
36 | |||
37 | CURLGNUTLS = " --with-gnutls=${STAGING_LIBDIR}/../ --without-ssl" | ||
38 | CURLGNUTLS_class-native = "--without-gnutls --with-ssl" | ||
39 | CURLGNUTLS_class-nativesdk = "--without-gnutls --without-ssl" | ||
40 | |||
41 | do_configure_prepend() { | ||
42 | sed -i s:OPT_GNUTLS/bin:OPT_GNUTLS:g ${S}/configure.ac | ||
43 | } | ||
44 | |||
45 | do_install_append() { | ||
46 | oe_multilib_header curl/curlbuild.h | ||
47 | } | ||
48 | |||
49 | PACKAGES =+ "libcurl libcurl-dev libcurl-staticdev libcurl-doc" | ||
50 | |||
51 | FILES_lib${BPN} = "${libdir}/lib*.so.*" | ||
52 | RRECOMMENDS_lib${BPN} += "ca-certificates" | ||
53 | FILES_lib${BPN}-dev = "${includedir} \ | ||
54 | ${libdir}/lib*.so \ | ||
55 | ${libdir}/lib*.la \ | ||
56 | ${libdir}/pkgconfig \ | ||
57 | ${datadir}/aclocal \ | ||
58 | ${bindir}/*-config" | ||
59 | FILES_lib${BPN}-staticdev = "${libdir}/lib*.a" | ||
60 | FILES_lib${BPN}-doc = "${mandir}/man3 \ | ||
61 | ${mandir}/man1/curl-config.1" | ||
62 | |||
63 | BBCLASSEXTEND = "native nativesdk" | ||