summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/boost/boost-build-native_1.84.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/boost/boost-build-native_1.84.0.bb')
-rw-r--r--meta/recipes-support/boost/boost-build-native_1.84.0.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost-build-native_1.84.0.bb b/meta/recipes-support/boost/boost-build-native_1.84.0.bb
new file mode 100644
index 0000000000..a345bac499
--- /dev/null
+++ b/meta/recipes-support/boost/boost-build-native_1.84.0.bb
@@ -0,0 +1,28 @@
1SUMMARY = "Boost.Build"
2DESCRIPTION = "B2 makes it easy to build C++ projects, everywhere."
3HOMEPAGE = "https://github.com/boostorg/build"
4SECTION = "devel"
5
6LICENSE = "BSL-1.0"
7LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
8
9SRC_URI = "git://github.com/boostorg/build;protocol=https;branch=master"
10SRCREV = "8d86b9a85407d73d6e8c631771f18c2a237d2d71"
11PE = "1"
12
13UPSTREAM_CHECK_GITTAGREGEX = "boost-(?P<pver>(\d+(\.\d+)+))"
14
15inherit native
16
17S = "${WORKDIR}/git"
18
19do_compile() {
20 ./bootstrap.sh
21}
22
23do_install() {
24 HOME=/var/run ./b2 install --prefix=${prefix} staging-prefix=${D}${prefix}
25}
26
27# The build is either release mode (pre-stripped) or debug (-O0).
28INSANE_SKIP:${PN} = "already-stripped"