summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bmaptool/bmaptool_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bmaptool/bmaptool_git.bb')
-rw-r--r--meta/recipes-support/bmaptool/bmaptool_git.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-support/bmaptool/bmaptool_git.bb b/meta/recipes-support/bmaptool/bmaptool_git.bb
new file mode 100644
index 0000000000..fd53c21c06
--- /dev/null
+++ b/meta/recipes-support/bmaptool/bmaptool_git.bb
@@ -0,0 +1,29 @@
1SUMMARY = "Tools to generate block map (AKA bmap) and flash images using bmap"
2DESCRIPTION = "bmaptool - tools to generate block map (AKA bmap) and flash images using \
3bmap. bmaptool is a generic tool for creating the block map (bmap) for a file, \
4and copying files using the block map. The idea is that large file containing \
5unused blocks, like raw system image files, can be copied or flashed a lot \
6faster with bmaptool than with traditional tools like "dd" or "cp"."
7HOMEPAGE = "https://github.com/yoctoproject/bmaptool"
8SECTION = "console/utils"
9LICENSE = "GPL-2.0-only"
10LIC_FILES_CHKSUM = "file://LICENSE;md5=b234ee4d69f5fce4486a80fdaf4a4263"
11
12SRC_URI = "git://github.com/yoctoproject/${BPN};branch=main;protocol=https"
13SRCREV = "2ff5750b8a3e0b36a9993c20e2ea10a07bc62085"
14S = "${WORKDIR}/git"
15BASEVER = "3.8.0"
16PV = "${BASEVER}+git"
17
18UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
19
20# Need df from coreutils
21RDEPENDS:${PN} = "python3-core python3-compression python3-misc python3-mmap python3-setuptools python3-fcntl python3-six coreutils"
22
23inherit setuptools3
24
25# For compatibility with layers before scarthgap
26RREPLACES:${PN} = "bmap-tools"
27RCONFLICTS:${PN} = "bmap-tools"
28
29BBCLASSEXTEND = "native nativesdk"