summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bdwgc/bdwgc_7.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bdwgc/bdwgc_7.2.bb')
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.2.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.2.bb b/meta/recipes-support/bdwgc/bdwgc_7.2.bb
new file mode 100644
index 0000000000..a0a5bffba9
--- /dev/null
+++ b/meta/recipes-support/bdwgc/bdwgc_7.2.bb
@@ -0,0 +1,41 @@
1SUMMARY = "A garbage collector for C and C++"
2
3DESCRIPTION = "The Boehm-Demers-Weiser conservative garbage collector can be\
4 used as a garbage collecting replacement for C malloc or C++ new. It allows\
5 you to allocate memory basically as you normally would, without explicitly\
6 deallocating memory that is no longer useful. The collector automatically\
7 recycles memory when it determines that it can no longer be otherwise\
8 accessed.\
9 The collector is also used by a number of programming language\
10 implementations that either use C as intermediate code, want to facilitate\
11 easier interoperation with C libraries, or just prefer the simple collector\
12 interface.\
13 Alternatively, the garbage collector may be used as a leak detector for C\
14 or C++ programs, though that is not its primary goal.\
15 Empirically, this collector works with most unmodified C programs, simply\
16 by replacing malloc with GC_malloc calls, replacing realloc with GC_realloc\
17 calls, and removing free calls."
18
19HOMEPAGE = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/"
20SECTION = "devel"
21LICENSE = "MIT & FSF-Unlimited & GPL-2.0"
22LIC_FILES_CHKSUM = "file://README.QUICK;md5=9b9dd874f6940641b6ab19893ee8f1cc \
23 file://doc/README;md5=92e7dd0334d1f672b699cd0aca08bef0 \
24 file://libatomic_ops/doc/LICENSING.txt;md5=607073e04548eac7d1f763e480477bab"
25
26REVISION = "d"
27
28SRC_URI = "http://www.hpl.hp.com/personal/Hans_Boehm/gc/gc_source/gc-${PV}${REVISION}.tar.gz"
29
30SRC_URI[md5sum] = "91340b28c61753a789eb6077675d87d2"
31SRC_URI[sha256sum] = "d9fe0ae8650d43746a48bfb394cab01a319f3809cee19f8ebd16aa985b511c5e"
32FILES_${PN}-doc = "/usr/share"
33
34PR = "r0"
35
36S = "${WORKDIR}/gc-${PV}"
37
38ARM_INSTRUCTION_SET = "arm"
39
40inherit autotools
41BBCLASSEXTEND = "native nativesdk"