summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bash-completion/bash-completion_2.13.0.bb')
-rw-r--r--meta/recipes-support/bash-completion/bash-completion_2.13.0.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb b/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
new file mode 100644
index 0000000000..f75d61e219
--- /dev/null
+++ b/meta/recipes-support/bash-completion/bash-completion_2.13.0.bb
@@ -0,0 +1,38 @@
1SUMMARY = "Programmable Completion for Bash 4"
2DESCRIPTION = "Collection of command line command completions for the Bash shell, \
3collection of helper functions to assist in creating new completions, \
4and set of facilities for loading completions automatically on demand, as well \
5as installing them."
6
7HOMEPAGE = "https://github.com/scop/bash-completion"
8BUGTRACKER = "https://github.com/scop/bash-completion/issues"
9
10LICENSE = "GPL-2.0-only"
11LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
12
13SECTION = "console/utils"
14
15SRC_URI = "${GITHUB_BASE_URI}/download/${PV}/${BPN}-${PV}.tar.xz"
16
17SRC_URI[sha256sum] = "c5f99a39e40f0d154c03ff15438e87ece1f5ac666336a4459899e2ff4bedf3d1"
18GITHUB_BASE_URI = "https://github.com/scop/bash-completion/releases"
19
20PARALLEL_MAKE = ""
21
22inherit autotools github-releases
23
24do_install:append() {
25 # compatdir
26 install -d ${D}${sysconfdir}/bash_completion.d/
27 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
28
29}
30
31RDEPENDS:${PN} = "bash"
32
33# Some recipes are providing ${PN}-bash-completion packages
34PACKAGES =+ "${PN}-extra"
35FILES:${PN}-extra = "${datadir}/${BPN}/completions/ \
36 ${datadir}/${BPN}/helpers/"
37
38BBCLASSEXTEND = "nativesdk"