summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/bash-completion/bash-completion_2.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/bash-completion/bash-completion_2.11.bb')
-rw-r--r--meta/recipes-support/bash-completion/bash-completion_2.11.bb39
1 files changed, 0 insertions, 39 deletions
diff --git a/meta/recipes-support/bash-completion/bash-completion_2.11.bb b/meta/recipes-support/bash-completion/bash-completion_2.11.bb
deleted file mode 100644
index f00e0fc5b7..0000000000
--- a/meta/recipes-support/bash-completion/bash-completion_2.11.bb
+++ /dev/null
@@ -1,39 +0,0 @@
1SUMMARY = "Programmable Completion for Bash 4"
2DESCRIPTION = "bash completion extends bash's standard completion behavior to \
3achieve complex command lines with just a few keystrokes."
4HOMEPAGE = "https://github.com/scop/bash-completion"
5BUGTRACKER = "https://github.com/scop/bash-completion/issues"
6
7LICENSE = "GPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
9
10SECTION = "console/utils"
11
12SRC_URI = "https://github.com/scop/bash-completion/releases/download/${PV}/${BPN}-${PV}.tar.xz"
13
14SRC_URI[md5sum] = "2514c6772d0de6254758b98c53f91861"
15SRC_URI[sha256sum] = "73a8894bad94dee83ab468fa09f628daffd567e8bef1a24277f1e9a0daf911ac"
16UPSTREAM_CHECK_REGEX = "bash-completion-(?P<pver>(?!2008).+)\.tar"
17UPSTREAM_CHECK_URI = "https://github.com/scop/bash-completion/releases"
18
19PARALLEL_MAKE = ""
20
21inherit autotools
22
23do_install_append() {
24 # compatdir
25 install -d ${D}${sysconfdir}/bash_completion.d/
26 echo '. ${datadir}/${BPN}/bash_completion' >${D}${sysconfdir}/bash_completion
27
28}
29
30RDEPENDS_${PN} = "bash"
31
32# Some recipes are providing ${PN}-bash-completion packages
33PACKAGES =+ "${PN}-extra"
34FILES_${PN}-extra = "${datadir}/${BPN}/completions/ \
35 ${datadir}/${BPN}/helpers/"
36
37FILES_${PN}-dev += "${datadir}/cmake"
38
39BBCLASSEXTEND = "nativesdk"