summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/aspell/aspell_0.60.8.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/aspell/aspell_0.60.8.1.bb')
-rw-r--r--meta/recipes-support/aspell/aspell_0.60.8.1.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-support/aspell/aspell_0.60.8.1.bb b/meta/recipes-support/aspell/aspell_0.60.8.1.bb
new file mode 100644
index 0000000000..0ea9b063e0
--- /dev/null
+++ b/meta/recipes-support/aspell/aspell_0.60.8.1.bb
@@ -0,0 +1,38 @@
1SUMMARY = "GNU Aspell spell-checker"
2
3DESCRIPTION = "Spell checker designed to eventually replace Ispell. \
4It can either be used as a library or as an independent spell checker. \
5Its main feature is that it does a superior job of suggesting possible \
6replacements for a misspelled word than just about any other spell \
7checker out there for the English language."
8
9SECTION = "console/utils"
10
11HOMEPAGE = "http://aspell.net/"
12
13LICENSE = "LGPL-2.0-only | LGPL-2.1-only"
14LIC_FILES_CHKSUM = "file://COPYING;md5=7fbc338309ac38fefcd64b04bb903e34"
15
16SRC_URI = "${GNU_MIRROR}/aspell/aspell-${PV}.tar.gz"
17SRC_URI[sha256sum] = "d6da12b34d42d457fa604e435ad484a74b2effcd120ff40acd6bb3fb2887d21b"
18
19PACKAGECONFIG ??= ""
20PACKAGECONFIG[curses] = "--enable-curses,--disable-curses,ncurses"
21
22PACKAGES += "libaspell libpspell aspell-utils"
23
24RDEPENDS:${PN}-utils += "perl"
25
26FILES:libaspell = "${libdir}/libaspell.so.* ${libdir}/aspell*"
27FILES:aspell-utils = "${bindir}/word-list-compress ${bindir}/aspell-import ${bindir}/run-with-aspell ${bindir}/pre*"
28FILES:${PN} = "${bindir}/aspell"
29FILES:libpspell = "${libdir}/libpspell.so.*"
30FILES:${PN}-dev += "${bindir}/pspell-config"
31
32ARM_INSTRUCTION_SET:armv4 = "arm"
33ARM_INSTRUCTION_SET:armv5 = "arm"
34ARM_INSTRUCTION_SET:armv6 = "arm"
35
36inherit autotools-brokensep gettext texinfo binconfig-disabled
37
38BINCONFIG = "${bindir}/pspell-config"