summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb')
-rw-r--r--meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb b/meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb
new file mode 100644
index 0000000000..00b6036502
--- /dev/null
+++ b/meta/recipes-support/argp-standalone/argp-standalone_1.4.1.bb
@@ -0,0 +1,31 @@
1# Copyright (C) 2015 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Glibc hierarchical argument parsing standalone library"
5DESCRIPTION = "Standalone version of arguments parsing functions from GLIBC"
6HOMEPAGE = "https://github.com/ericonr/argp-standalone"
7LICENSE = "LGPL-2.1-only"
8LIC_FILES_CHKSUM = "file://argp.h;beginline=1;endline=20;md5=464f2cfb1c35a5123f9e309d7afd79f8"
9SECTION = "libs"
10
11SRC_URI = "git://github.com/ericonr/argp-standalone;branch=master;protocol=https \
12 file://out_of_tree_build.patch \
13 "
14SRCREV = "e5fe9ad9e83e6765cf8fa787f903d4c6792338b5"
15S = "${WORKDIR}/git"
16
17inherit autotools
18
19CFLAGS += "-fPIC -U__OPTIMIZE__"
20
21DEV_PKG_DEPENDENCY = ""
22RDEPENDS:${PN}-staticdev = ""
23
24do_install() {
25 install -D -m 0644 ${B}/libargp.a ${D}${libdir}/libargp.a
26 install -D -m 0644 ${S}/argp.h ${D}${includedir}/argp.h
27}
28#
29# We will skip parsing for non-musl systems
30#
31COMPATIBLE_HOST = ".*-musl.*"