summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/apr/apr-util_1.6.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/apr/apr-util_1.6.3.bb')
-rw-r--r--meta/recipes-support/apr/apr-util_1.6.3.bb97
1 files changed, 97 insertions, 0 deletions
diff --git a/meta/recipes-support/apr/apr-util_1.6.3.bb b/meta/recipes-support/apr/apr-util_1.6.3.bb
new file mode 100644
index 0000000000..1371e262dd
--- /dev/null
+++ b/meta/recipes-support/apr/apr-util_1.6.3.bb
@@ -0,0 +1,97 @@
1SUMMARY = "Apache Portable Runtime (APR) companion library"
2HOMEPAGE = "http://apr.apache.org/"
3SECTION = "libs"
4DEPENDS = "apr expat"
5
6BBCLASSEXTEND = "native nativesdk"
7
8LICENSE = "Apache-2.0"
9LIC_FILES_CHKSUM = "file://LICENSE;md5=158aa0b1efe0c12f23d4b007ddb9a5db \
10 file://include/apu_version.h;endline=15;md5=823b3d1a7225df8f7b68a69c3c2b4c71"
11
12SRC_URI = "${APACHE_MIRROR}/apr/${BPN}-${PV}.tar.gz \
13 file://configfix.patch \
14 file://configure_fixes.patch \
15 file://0001-test_transformation-Check-if-transform-is-supported-.patch \
16 file://run-ptest \
17 "
18
19SRC_URI[sha256sum] = "2b74d8932703826862ca305b094eef2983c27b39d5c9414442e9976a9acf1983"
20
21EXTRA_OECONF = "--with-apr=${STAGING_BINDIR_CROSS}/apr-1-config \
22 --without-odbc \
23 --without-pgsql \
24 --without-sqlite2 \
25 --with-expat=${STAGING_DIR_HOST}${prefix}"
26
27
28inherit autotools lib_package binconfig multilib_script
29
30MULTILIB_SCRIPTS = "${PN}-dev:${bindir}/apu-1-config"
31
32OE_BINCONFIG_EXTRA_MANGLE = " -e 's:location=source:location=installed:'"
33
34do_configure:append() {
35 if [ "${CLASSOVERRIDE}" = "class-target" ]; then
36 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${B}/build/rules.mk
37 sed -i -e 's#^CFLAGS=.*#CFLAGS=${TARGET_CFLAGS}#g' ${B}/build/rules.mk
38 fi
39}
40do_configure:prepend:class-native() {
41 mkdir ${B}/build
42 cp ${STAGING_DATADIR_NATIVE}/apr/apr_rules.mk ${B}/build/rules.mk
43}
44do_configure:append:class-native() {
45 sed -i "s#LIBTOOL=\$(SHELL) \$(apr_builddir)#LIBTOOL=\$(SHELL) ${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk
46 # sometimes there isn't SHELL
47 sed -i "s#LIBTOOL=\$(apr_builddir)#LIBTOOL=${STAGING_BINDIR_NATIVE}#" ${B}/build/rules.mk
48}
49
50do_configure:prepend:class-nativesdk() {
51 cp ${STAGING_DATADIR}/apr/apr_rules.mk ${S}/build/rules.mk
52 sed -i -e 's#^CFLAGS=.*#CFLAGS=${TARGET_CFLAGS}#g' ${S}/build/rules.mk
53}
54
55do_configure:append:class-nativesdk() {
56 sed -i "s#\(apr_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${B}/build/rules.mk
57 sed -i "s#\(apr_builders\)=.*#\1=${STAGING_DATADIR}/build-1#" ${B}/build/rules.mk
58 sed -i "s#\(top_builddir\)=.*#\1=${STAGING_DATADIR}/build-1#" ${B}/build/rules.mk
59 sed -i "s#\(LIBTOOL=\$(apr_builddir)\).*#\1/libtool#" ${B}/build/rules.mk
60}
61
62do_install:append:class-target() {
63 sed -i -e 's,${STAGING_DIR_HOST},,g' \
64 -e 's,APU_SOURCE_DIR=.*,APR_SOURCE_DIR=,g' \
65 -e 's,APU_BUILD_DIR=.*,APR_BUILD_DIR=,g' ${D}${bindir}/apu-1-config
66}
67
68PACKAGECONFIG ??= "crypto gdbm"
69PACKAGECONFIG[ldap] = "--with-ldap,--without-ldap,openldap"
70PACKAGECONFIG[crypto] = "--with-openssl=${STAGING_DIR_HOST}${prefix} --with-crypto,--without-crypto,openssl"
71PACKAGECONFIG[sqlite3] = "--with-sqlite3=${STAGING_DIR_HOST}${prefix},--without-sqlite3,sqlite3"
72PACKAGECONFIG[gdbm] = "--with-dbm=gdbm --with-gdbm=${STAGING_DIR_HOST}${prefix},--without-gdbm,gdbm"
73
74#files ${libdir}/apr-util-1/*.so are not symlinks but loadable modules thus they are packaged in ${PN}
75FILES:${PN} += "${libdir}/apr-util-1/apr*${SOLIBS} ${libdir}/apr-util-1/apr*${SOLIBSDEV}"
76FILES:${PN}-dev += "${libdir}/aprutil.exp ${libdir}/apr-util-1/*.la"
77FILES:${PN}-staticdev += "${libdir}/apr-util-1/*.a"
78
79INSANE_SKIP:${PN} += "dev-so"
80
81inherit ptest
82
83RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-gconv-iso8859-1 glibc-gconv-iso8859-2 glibc-gconv-utf-7"
84RDEPENDS:${PN}-ptest += "libgcc"
85
86do_compile_ptest() {
87 cd ${B}/test
88 oe_runmake
89}
90
91do_install_ptest() {
92 t=${D}${PTEST_PATH}/test
93 mkdir $t
94 for i in testall data; do \
95 cp -r ${B}/test/$i $t; \
96 done
97}