summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support/appstream/appstream_1.0.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-support/appstream/appstream_1.0.2.bb')
-rw-r--r--meta/recipes-support/appstream/appstream_1.0.2.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta/recipes-support/appstream/appstream_1.0.2.bb b/meta/recipes-support/appstream/appstream_1.0.2.bb
new file mode 100644
index 0000000000..7eb12a04c5
--- /dev/null
+++ b/meta/recipes-support/appstream/appstream_1.0.2.bb
@@ -0,0 +1,44 @@
1SUMMARY = "AppStream is a collaborative effort for making machine-readable software metadata easily available."
2HOMEPAGE = "https://github.com/ximion/appstream"
3LICENSE = "LGPL-2.1-only"
4LIC_FILES_CHKSUM = "file://COPYING;md5=435ed639f84d4585d93824e7da3d85da"
5
6DEPENDS = " \
7 appstream-native \
8 curl-native \
9 curl \
10 docbook-xml-dtd4-native \
11 gperf-native \
12 glib-2.0 \
13 libyaml \
14 libxml2 \
15 libxmlb \
16 libxslt-native \
17 itstool-native \
18 docbook-xsl-stylesheets-native \
19 python3-pygments-native \
20"
21
22inherit meson gobject-introspection gettext gi-docgen pkgconfig vala
23
24GIR_MESON_OPTION = "gir"
25GIDOCGEN_MESON_OPTION = "apidocs"
26
27SRC_URI = " \
28 https://www.freedesktop.org/software/appstream/releases/AppStream-${PV}.tar.xz \
29 file://0001-remove-hardcoded-path.patch \
30"
31SRC_URI[sha256sum] = "1a5148ca97dcbf5eb6e9c380278bb0d20938569292ea8652df1b3cac8bd2736b"
32
33S = "${WORKDIR}/AppStream-${PV}"
34
35PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
36
37PACKAGECONFIG[systemd] = "-Dsystemd=true,-Dsystemd=false,systemd"
38PACKAGECONFIG[stemming] = "-Dstemming=true,-Dstemming=false,libstemmer"
39
40FILES:${PN} += "${datadir}"
41
42EXTRA_OEMESON += "${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-Dvapi=true', '-Dvapi=false', d)}"
43
44BBCLASSEXTEND = "native"