summaryrefslogtreecommitdiffstats
path: root/meta/recipes-sato/webkit/webkitgtk_2.30.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.30.1.bb')
-rw-r--r--meta/recipes-sato/webkit/webkitgtk_2.30.1.bb134
1 files changed, 134 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.30.1.bb b/meta/recipes-sato/webkit/webkitgtk_2.30.1.bb
new file mode 100644
index 0000000000..7689266304
--- /dev/null
+++ b/meta/recipes-sato/webkit/webkitgtk_2.30.1.bb
@@ -0,0 +1,134 @@
1SUMMARY = "WebKit web rendering engine for the GTK+ platform"
2HOMEPAGE = "https://www.webkitgtk.org/"
3BUGTRACKER = "https://bugs.webkit.org/"
4
5LICENSE = "BSD & LGPLv2+"
6LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \
7 file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \
8 file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \
9 file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \
10 "
11
12SRC_URI = "https://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \
13 file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \
14 file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \
15 file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \
16 file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \
17 file://0001-Enable-THREADS_PREFER_PTHREAD_FLAG.patch \
18 file://0001-Fix-build-with-musl.patch \
19 file://include_array.patch \
20 "
21SRC_URI[sha256sum] = "17c59dfdadb7377192e9b59bc56c8a029c9fad4f38ed732b652bf33d0bd5d6b1"
22
23inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gtk-doc
24
25ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
26REQUIRED_DISTRO_FEATURES = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'opengl', '', d)}"
27
28CVE_PRODUCT = "webkitgtk webkitgtk\+"
29
30DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libgcrypt \
31 gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \
32 pango icu bison-native gawk intltool-native libwebp \
33 atk udev harfbuzz jpeg libpng librsvg libtheora libvorbis \
34 ruby-native libnotify gstreamer1.0-plugins-bad \
35 gettext-native glib-2.0 glib-2.0-native libtasn1 \
36 "
37
38PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd wayland x11', d)} \
39 ${@bb.utils.contains('DISTRO_FEATURES', 'x11 opengl', 'webgl opengl', '', d)} \
40 ${@bb.utils.contains('DISTRO_FEATURES', 'x11', '', 'webgl gles2', d)} \
41 enchant \
42 libsecret \
43 "
44
45PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland libwpe wpebackend-fdo wayland-native"
46PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11 libxcomposite libxdamage libxrender libxt"
47PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue"
48PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant2"
49PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2"
50PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl"
51PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl"
52PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret"
53PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen"
54PACKAGECONFIG[woff2] = "-DUSE_WOFF2=ON,-DUSE_WOFF2=OFF,woff2"
55PACKAGECONFIG[openjpeg] = "-DUSE_OPENJPEG=ON,-DUSE_OPENJPEG=OFF,openjpeg"
56PACKAGECONFIG[systemd] = "-DUSE_SYSTEMD=ON,-DUSE_SYSTEMD=off,systemd"
57
58# webkitgtk is full of /usr/bin/env python, particular for generating docs
59do_configure[postfuncs] += "setup_python_link"
60setup_python_link() {
61 if [ ! -e ${STAGING_BINDIR_NATIVE}/python ]; then
62 ln -s `which python3` ${STAGING_BINDIR_NATIVE}/python
63 fi
64}
65
66EXTRA_OECMAKE = " \
67 -DPORT=GTK \
68 -DCMAKE_BUILD_TYPE=Release \
69 ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \
70 ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \
71 -DENABLE_MINIBROWSER=ON \
72 -DPYTHON_EXECUTABLE=`which python3` \
73 -DENABLE_BUBBLEWRAP_SANDBOX=OFF \
74 "
75
76# Javascript JIT is not supported on ARC
77EXTRA_OECMAKE_append_arc = " -DENABLE_JIT=OFF "
78# By default 25-bit "medium" calls are used on ARC
79# which is not enough for binaries larger than 32 MiB
80CFLAGS_append_arc = " -mlong-calls"
81CXXFLAGS_append_arc = " -mlong-calls"
82
83# Javascript JIT is not supported on powerpc
84EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF "
85EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF "
86
87# ARM JIT code does not build on ARMv4/5/6 anymore
88EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF "
89EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF "
90EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF "
91
92EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF "
93EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF "
94
95# JIT and gold linker does not work on RISCV
96EXTRA_OECMAKE_append_riscv32 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
97EXTRA_OECMAKE_append_riscv64 = " -DUSE_LD_GOLD=OFF -DENABLE_JIT=OFF"
98
99# JIT not supported on MIPS either
100EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF -DENABLE_C_LOOP=ON "
101
102# JIT not supported on X32
103# An attempt was made to upstream JIT support for x32 in
104# https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as
105# unresolved due to limited X32 adoption.
106EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF "
107
108SECURITY_CFLAGS_remove_aarch64 = "-fpie"
109SECURITY_CFLAGS_append_aarch64 = " -fPIE"
110
111FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so"
112
113RRECOMMENDS_${PN} += "ca-certificates shared-mime-info"
114
115# http://errors.yoctoproject.org/Errors/Details/20370/
116ARM_INSTRUCTION_SET_armv4 = "arm"
117ARM_INSTRUCTION_SET_armv5 = "arm"
118ARM_INSTRUCTION_SET_armv6 = "arm"
119
120# https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474
121# https://bugs.webkit.org/show_bug.cgi?id=159880
122# JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime.
123# Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb).
124ARM_INSTRUCTION_SET_armv7a = "thumb"
125ARM_INSTRUCTION_SET_armv7r = "thumb"
126ARM_INSTRUCTION_SET_armv7ve = "thumb"
127
128# introspection inside qemu-arm hangs forever on musl/arm builds
129# therefore disable GI_DATA
130GI_DATA_ENABLED_libc-musl_armv7a = "False"
131GI_DATA_ENABLED_libc-musl_armv7ve = "False"
132
133# Can't be built with ccache
134CCACHE_DISABLE = "1"