diff options
Diffstat (limited to 'meta/recipes-sato/webkit/webkitgtk_2.18.5.bb')
-rw-r--r-- | meta/recipes-sato/webkit/webkitgtk_2.18.5.bb | 121 |
1 files changed, 121 insertions, 0 deletions
diff --git a/meta/recipes-sato/webkit/webkitgtk_2.18.5.bb b/meta/recipes-sato/webkit/webkitgtk_2.18.5.bb new file mode 100644 index 0000000000..a64aee22e6 --- /dev/null +++ b/meta/recipes-sato/webkit/webkitgtk_2.18.5.bb | |||
@@ -0,0 +1,121 @@ | |||
1 | SUMMARY = "WebKit web rendering engine for the GTK+ platform" | ||
2 | HOMEPAGE = "http://www.webkitgtk.org/" | ||
3 | BUGTRACKER = "http://bugs.webkit.org/" | ||
4 | |||
5 | LICENSE = "BSD & LGPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://Source/JavaScriptCore/COPYING.LIB;md5=d0c6d6397a5d84286dda758da57bd691 \ | ||
7 | file://Source/WebCore/LICENSE-APPLE;md5=4646f90082c40bcf298c285f8bab0b12 \ | ||
8 | file://Source/WebCore/LICENSE-LGPL-2;md5=36357ffde2b64ae177b2494445b79d21 \ | ||
9 | file://Source/WebCore/LICENSE-LGPL-2.1;md5=a778a33ef338abbaf8b8a7c36b6eec80 \ | ||
10 | " | ||
11 | |||
12 | SRC_URI = "http://www.webkitgtk.org/releases/${BPN}-${PV}.tar.xz \ | ||
13 | file://0001-FindGObjectIntrospection.cmake-prefix-variables-obta.patch \ | ||
14 | file://0001-When-building-introspection-files-add-CMAKE_C_FLAGS-.patch \ | ||
15 | file://0001-OptionsGTK.cmake-drop-the-hardcoded-introspection-gt.patch \ | ||
16 | file://0001-Fix-racy-parallel-build-of-WebKit2-4.0.gir.patch \ | ||
17 | file://0001-Tweak-gtkdoc-settings-so-that-gtkdoc-generation-work.patch \ | ||
18 | file://x32_support.patch \ | ||
19 | file://cross-compile.patch \ | ||
20 | file://detect-atomics-during-configure.patch \ | ||
21 | file://0001-WebKitMacros-Append-to-I-and-not-to-isystem.patch \ | ||
22 | file://0001-Fix-build-with-musl.patch \ | ||
23 | " | ||
24 | |||
25 | SRC_URI[md5sum] = "af18c2cfa00cadfd0b4d8db21cab011d" | ||
26 | SRC_URI[sha256sum] = "0c6d80cc7eb5d32f8063041fa11a1a6f17a29765c2f69c6bc862cd47c2d539b8" | ||
27 | |||
28 | inherit cmake pkgconfig gobject-introspection perlnative distro_features_check upstream-version-is-even gtk-doc | ||
29 | |||
30 | # depends on libxt | ||
31 | REQUIRED_DISTRO_FEATURES = "x11" | ||
32 | |||
33 | DEPENDS = "zlib libsoup-2.4 curl libxml2 cairo libxslt libxt libidn libgcrypt \ | ||
34 | gtk+3 gstreamer1.0 gstreamer1.0-plugins-base flex-native gperf-native sqlite3 \ | ||
35 | pango icu bison-native gawk intltool-native libwebp \ | ||
36 | atk udev harfbuzz jpeg libpng pulseaudio librsvg libtheora libvorbis libxcomposite libxtst \ | ||
37 | ruby-native libnotify gstreamer1.0-plugins-bad \ | ||
38 | gettext-native glib-2.0 glib-2.0-native libtasn1 \ | ||
39 | " | ||
40 | |||
41 | PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'x11', 'wayland' ,d)} \ | ||
42 | ${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'webgl opengl', '' ,d)} \ | ||
43 | enchant \ | ||
44 | libsecret \ | ||
45 | " | ||
46 | |||
47 | PACKAGECONFIG[wayland] = "-DENABLE_WAYLAND_TARGET=ON,-DENABLE_WAYLAND_TARGET=OFF,wayland" | ||
48 | PACKAGECONFIG[x11] = "-DENABLE_X11_TARGET=ON,-DENABLE_X11_TARGET=OFF,virtual/libx11" | ||
49 | PACKAGECONFIG[geoclue] = "-DENABLE_GEOLOCATION=ON,-DENABLE_GEOLOCATION=OFF,geoclue" | ||
50 | PACKAGECONFIG[enchant] = "-DENABLE_SPELLCHECK=ON,-DENABLE_SPELLCHECK=OFF,enchant" | ||
51 | PACKAGECONFIG[gtk2] = "-DENABLE_PLUGIN_PROCESS_GTK2=ON,-DENABLE_PLUGIN_PROCESS_GTK2=OFF,gtk+" | ||
52 | PACKAGECONFIG[gles2] = "-DENABLE_GLES2=ON,-DENABLE_GLES2=OFF,virtual/libgles2" | ||
53 | PACKAGECONFIG[webgl] = "-DENABLE_WEBGL=ON,-DENABLE_WEBGL=OFF,virtual/libgl" | ||
54 | PACKAGECONFIG[opengl] = "-DENABLE_OPENGL=ON,-DENABLE_OPENGL=OFF,virtual/libgl" | ||
55 | PACKAGECONFIG[libsecret] = "-DUSE_LIBSECRET=ON,-DUSE_LIBSECRET=OFF,libsecret" | ||
56 | PACKAGECONFIG[libhyphen] = "-DUSE_LIBHYPHEN=ON,-DUSE_LIBHYPHEN=OFF,libhyphen" | ||
57 | |||
58 | EXTRA_OECMAKE = " \ | ||
59 | -DPORT=GTK \ | ||
60 | -DCMAKE_BUILD_TYPE=Release \ | ||
61 | ${@bb.utils.contains('GI_DATA_ENABLED', 'True', '-DENABLE_INTROSPECTION=ON', '-DENABLE_INTROSPECTION=OFF', d)} \ | ||
62 | ${@bb.utils.contains('GTKDOC_ENABLED', 'True', '-DENABLE_GTKDOC=ON', '-DENABLE_GTKDOC=OFF', d)} \ | ||
63 | -DENABLE_MINIBROWSER=ON \ | ||
64 | -DPYTHON_EXECUTABLE=`which python` \ | ||
65 | " | ||
66 | |||
67 | # GL/GLES header clash: both define the same thing, differently, on 32 bit x86 | ||
68 | EXTRA_OECMAKE_append_x86 = " -DUSE_GSTREAMER_GL=OFF " | ||
69 | EXTRA_OECMAKE_append_x86-x32 = " -DUSE_GSTREAMER_GL=OFF " | ||
70 | |||
71 | # Javascript JIT is not supported on powerpc | ||
72 | EXTRA_OECMAKE_append_powerpc = " -DENABLE_JIT=OFF " | ||
73 | EXTRA_OECMAKE_append_powerpc64 = " -DENABLE_JIT=OFF " | ||
74 | |||
75 | # ARM JIT code does not build on ARMv4/5/6 anymore | ||
76 | EXTRA_OECMAKE_append_armv5 = " -DENABLE_JIT=OFF " | ||
77 | EXTRA_OECMAKE_append_armv6 = " -DENABLE_JIT=OFF " | ||
78 | EXTRA_OECMAKE_append_armv4 = " -DENABLE_JIT=OFF " | ||
79 | |||
80 | # binutils 2.25.1 has a bug on aarch64: | ||
81 | # https://sourceware.org/bugzilla/show_bug.cgi?id=18430 | ||
82 | EXTRA_OECMAKE_append_aarch64 = " -DUSE_LD_GOLD=OFF " | ||
83 | EXTRA_OECMAKE_append_mipsarch = " -DUSE_LD_GOLD=OFF " | ||
84 | EXTRA_OECMAKE_append_powerpc = " -DUSE_LD_GOLD=OFF " | ||
85 | EXTRA_OECMAKE_append_toolchain-clang = " -DUSE_LD_GOLD=OFF " | ||
86 | |||
87 | EXTRA_OECMAKE_append_aarch64 = " -DWTF_CPU_ARM64_CORTEXA53=ON" | ||
88 | |||
89 | # JIT not supported on MIPS either | ||
90 | EXTRA_OECMAKE_append_mipsarch = " -DENABLE_JIT=OFF " | ||
91 | |||
92 | # JIT not supported on X32 | ||
93 | # An attempt was made to upstream JIT support for x32 in | ||
94 | # https://bugs.webkit.org/show_bug.cgi?id=100450, but this was closed as | ||
95 | # unresolved due to limited X32 adoption. | ||
96 | EXTRA_OECMAKE_append_x86-x32 = " -DENABLE_JIT=OFF " | ||
97 | |||
98 | SECURITY_CFLAGS_remove_aarch64 = "-fpie" | ||
99 | SECURITY_CFLAGS_append_aarch64 = " -fPIE" | ||
100 | |||
101 | FILES_${PN} += "${libdir}/webkit2gtk-4.0/injected-bundle/libwebkit2gtkinjectedbundle.so" | ||
102 | |||
103 | RRECOMMENDS_${PN} += "ca-certificates shared-mime-info" | ||
104 | |||
105 | # http://errors.yoctoproject.org/Errors/Details/20370/ | ||
106 | ARM_INSTRUCTION_SET_armv4 = "arm" | ||
107 | ARM_INSTRUCTION_SET_armv5 = "arm" | ||
108 | ARM_INSTRUCTION_SET_armv6 = "arm" | ||
109 | |||
110 | # https://bugzilla.yoctoproject.org/show_bug.cgi?id=9474 | ||
111 | # https://bugs.webkit.org/show_bug.cgi?id=159880 | ||
112 | # JSC JIT can build on ARMv7 with -marm, but doesn't work on runtime. | ||
113 | # Upstream only tests regularly the JSC JIT on ARMv7 with Thumb2 (-mthumb). | ||
114 | ARM_INSTRUCTION_SET_armv7a = "thumb" | ||
115 | ARM_INSTRUCTION_SET_armv7r = "thumb" | ||
116 | ARM_INSTRUCTION_SET_armv7ve = "thumb" | ||
117 | |||
118 | # qemu: uncaught target signal 11 (Segmentation fault) - core dumped | ||
119 | # Segmentation fault | ||
120 | GI_DATA_ENABLED_armv7a = "False" | ||
121 | GI_DATA_ENABLED_armv7ve = "False" | ||